summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordreieck2022-06-04 17:15:15 +0200
committerdreieck2022-06-04 17:15:15 +0200
commit88b0b10839a634cf54785e6472ff5d044575d477 (patch)
tree76243cb4046134e1a1255006e322a31779752281
downloadaur-88b0b10839a634cf54785e6472ff5d044575d477.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD60
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3481dc4aa944
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = balong-fbtools-git
+ pkgdesc = Utilities for working with flash modems on the balong platform. Contains 'fbrflash'.
+ pkgver = r36.20171009.22a228c
+ pkgrel = 2
+ url = https://github.com/forth32/balong-fbtools
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = libusb
+ provides = balong-fbtools
+ provides = fbrflash
+ provides = fbrflash-git=r36.20171009.22a228c
+ conflicts = balong-fbtools
+ conflicts = fbrflash
+ source = balong-fbtools::git+https://github.com/forth32/balong-fbtools.git
+ source = helpmessages_english.md::http://ix.io/3Znm
+ sha256sums = SKIP
+ sha256sums = ab70bd1ab7b324ea73e3225d13500b1ecda7663434a8fa71b5457dd229087440
+
+pkgname = balong-fbtools-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4620f81c9867
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: dreieck
+
+_pkgname="balong-fbtools"
+pkgname="${_pkgname}-git"
+pkgver=r36.20171009.22a228c
+pkgrel=2
+pkgdesc="Utilities for working with flash modems on the balong platform. Contains 'fbrflash'."
+arch=('i686' 'x86_64')
+url="https://github.com/forth32/${_pkgname}"
+license=('GPL3')
+depends=('libusb')
+makedepends=('git')
+optdepends=()
+provides=(
+ "${_pkgname}"
+ 'fbrflash'
+ "fbrflash-git=${pkgver}"
+)
+conflicts=(
+ "${_pkgname}"
+ 'fbrflash'
+)
+
+source=(
+ "${_pkgname}::git+https://github.com/forth32/${_pkgname}.git"
+ 'helpmessages_english.md'::"http://ix.io/3Znm"
+)
+sha256sums=(
+ 'SKIP'
+ 'ab70bd1ab7b324ea73e3225d13500b1ecda7663434a8fa71b5457dd229087440'
+)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ _rev="$(git rev-list --count HEAD)"
+ _date="$(git log -1 --date=format:"%Y%m%d" --format="%ad")"
+ _hash="$(git rev-parse --short HEAD)"
+
+ if [ -z "${_rev}" ]; then
+ error "Git commit count could not be determined."
+ return 1
+ else
+ printf '%s' "r${_rev}.${_date}.${_hash}"
+ fi
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -D -v -m755 fbrflash "${pkgdir}/usr/bin/fbrflash"
+
+ install -D -v -m644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -D -v -m644 "${srcdir}/helpmessages_english.md" "${pkgdir}/usr/share/doc/${_pkgname}/helpmessages_english.md"
+}