summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-03-24 20:49:28 +0100
committergit user2024-03-24 20:49:28 +0100
commitde0ba4b7bc7d064a239136067fe601df3b595cf2 (patch)
tree874c50b40717a465ddd392a987657d1a0644f1f2
parent7f80254ee87c143674d8492f34396887892c007e (diff)
downloadaur-de0ba4b7bc7d064a239136067fe601df3b595cf2.tar.gz
Now serving `helpmessages_english.md` locally.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--helpmessages_english.md60
3 files changed, 65 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d8f6e74c539..1e054e4873c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = balong-fbtools-git
pkgdesc = Utilities for working with flash modems on the balong platform. Contains 'fbrflash'.
pkgver = r36.20171009.22a228c
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/forth32/balong-fbtools
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = balong-fbtools-git
conflicts = balong-fbtools
conflicts = fbrflash
source = balong-fbtools::git+https://github.com/forth32/balong-fbtools.git
- source = balong-fbtools-r36.20171009.22a228c_-_helpmessages_english.md::http://ix.io/3Znm
+ source = helpmessages_english.md
sha256sums = SKIP
sha256sums = ab70bd1ab7b324ea73e3225d13500b1ecda7663434a8fa71b5457dd229087440
diff --git a/PKGBUILD b/PKGBUILD
index 7b13086c393b..01a1a2b694e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="balong-fbtools"
pkgname="${_pkgname}-git"
pkgver=r36.20171009.22a228c
-pkgrel=3
+pkgrel=4
pkgdesc="Utilities for working with flash modems on the balong platform. Contains 'fbrflash'."
arch=('i686' 'x86_64')
url="https://github.com/forth32/${_pkgname}"
@@ -23,7 +23,7 @@ conflicts=(
source=(
"${_pkgname}::git+https://github.com/forth32/${_pkgname}.git"
- "${_pkgname}-${pkgver}_-_helpmessages_english.md::http://ix.io/3Znm"
+ "helpmessages_english.md"
)
sha256sums=(
'SKIP'
@@ -62,5 +62,5 @@ package() {
install -D -v -m755 fbrflash "${pkgdir}/usr/bin/fbrflash"
install -D -v -m644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
- install -D -v -m644 "${srcdir}/${_pkgname}-${pkgver}_-_helpmessages_english.md" "${pkgdir}/usr/share/doc/${_pkgname}/helpmessages_english.md"
+ install -D -v -m644 "${srcdir}/helpmessages_english.md" "${pkgdir}/usr/share/doc/${_pkgname}/helpmessages_english.md"
}
diff --git a/helpmessages_english.md b/helpmessages_english.md
new file mode 100644
index 000000000000..eb4d4cd08eb2
--- /dev/null
+++ b/helpmessages_english.md
@@ -0,0 +1,60 @@
+# English translation of the help messages of the software at https://github.com/forth32/balong-fbtools.
+
+## `README.md`:
+
+Utilities for working with flash modems on the balong platform
+
+The utilities work through the fastboot-interface. To put the modem in this mode you need to do two things:
+
+1. In the first byte of nvram cell 53521 set the lowest bit to 1.
+ For example it goes like this:
+ ```
+ at^nvwrex=53521,0,64,3D E0 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 01 00 00 00 00 00 00 00 00 00 00 00 00
+ ```
+
+2. Restart the modem in fastboot mode. This can be done from the modem's linux console with the command
+ ```
+ ecall power_off_reboot_operation
+ ```
+
+After that the modem goes into the fastboot-mode. This will create a device with `vid=12d1`, the pid for E3372 modems is `36dd`. No logical devices are created in this usb configuration. You can work directly with raw device in libusb mode (specify key -u in command). Or you can connect option driver to this device and run the following command from the root:
+
+```
+echo "12d1 " >/sys/bus/usb-serial/drivers/option1/new_id
+```
+
+This will create a device `/dev/ttyUSBx` which can be used as a serial port (`-p` switch).
+
+
+## Output of `fbrflash`:
+
+```
+Error opening device PID=36dd
+```
+
+
+## Output of `fbrflash -h`:
+
+```
+Utility to read flash modems on the balong platform.
+Modem must be in fastboot mode.
+
+Usage:
+ ./fbrflash [options]
+
+The following options are allowed:
+
+-p <tty> - fastboot serial port in serial mode (by default /dev/ttyUSB0)
+-u <pid> - PID of USB device fastboot in libusb mode
+-m - show partition map
+-n - show nand flash settings
+-t <file> - take partition table from specified file instead of reading from modem
+-o - read from OOB (in the format 2048+64), without option - only data for B315 it is read in "raw" format
+-y - read with tag yaffs2 (in format 2048+16 or 4096+16)
+
+ --- Read mode selection ---
+
+-f # - read partition with specified number, key can be specified more than once
+-r start[:len] - read block len from block start (by default len=1)
+without option -r and -f - read all sections of the modem
+```