summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2017-02-02 20:29:50 +0100
committerfelics@felics-tablet2017-02-02 20:29:50 +0100
commitcf6b050b66a78c5045d00ef6d8987461e67f4b8b (patch)
tree2591ea13705d878998cf85f86efd2f1f2eee31fc
downloadaur-cf6b050b66a78c5045d00ef6d8987461e67f4b8b.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD54
-rw-r--r--README.english.md4
-rw-r--r--helpmessages_english.txt80
4 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bcf1b1d1960
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = balong-usbdload-git
+ pkgdesc = Low level USB Flashing/ downloader utility for Huawei E3372 and other modems baesd on Balong v7. Includes temporary usb loader "firmware" for some devices.
+ pkgver = r59.762a458
+ pkgrel = 2
+ url = http://github.com/forth32/balong-usbdload
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ optdepends = balongflash: For flashing firmware after downloading temporary USB downloader code with balong-usbdload.
+ provides = balong-usbdload=r59.762a458
+ provides = balong-usbdload-data=r59.762a458
+ conflicts = balong-usbdload
+ source = balong-usbdload::git+https://github.com/forth32/balong-usbdload.git
+ source = helpmessages_english.txt
+ source = README.english.md
+ sha256sums = SKIP
+ sha256sums = 96346a31d173909514a29dca5e2a7eb0540b635ae42220b179f2654a35e9d2ab
+ sha256sums = b418646e48436a8b55733bf270e3050cbf6ecaa1ec31862f06754333dd691594
+
+pkgname = balong-usbdload-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7def787c790
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: dreieck
+
+_pkgname=balong-usbdload
+pkgname="${_pkgname}-git"
+_pkgver=latest
+pkgver=r59.762a458
+pkgrel=2
+pkgdesc='Low level USB Flashing/ downloader utility for Huawei E3372 and other modems baesd on Balong v7. Includes temporary usb loader "firmware" for some devices.'
+arch=('i686' 'x86_64')
+url="http://github.com/forth32/balong-usbdload"
+license=('GPLv3')
+depends=()
+optdepends=("balongflash: For flashing firmware after downloading temporary USB downloader code with ${_pkgname}.")
+makedepends=('git')
+provides=(
+ "${_pkgname}=${pkgver}"
+ "balong-usbdload-data=${pkgver}"
+)
+conflicts=("${_pkgname}")
+options=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+source=(
+ "${_pkgname}::git+https://github.com/forth32/balong-usbdload.git"
+ "helpmessages_english.txt"
+ "README.english.md"
+)
+
+sha256sums=(
+ 'SKIP'
+ '96346a31d173909514a29dca5e2a7eb0540b635ae42220b179f2654a35e9d2ab'
+ 'b418646e48436a8b55733bf270e3050cbf6ecaa1ec31862f06754333dd691594'
+)
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -v -d -m755 "${pkgdir}/usr/bin/"
+ install -v -m755 balong-usbdload loader-patch ptable-injector "${pkgdir}/usr/bin"
+ install -v -d -m755 "${pkgdir}/usr/share/${_pkgname}/data"
+ install -v -m644 *.bin "${pkgdir}/usr/share/${_pkgname}/data"
+
+ install -v -D -m644 README.md "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+ install -v -D -m644 "${srcdir}/README.english.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.english.md"
+ install -v -D -m644 "${srcdir}/helpmessages_english.txt" "${pkgdir}/usr/share/doc/${_pkgname}/helpmessages_english.txt"
+}
diff --git a/README.english.md b/README.english.md
new file mode 100644
index 000000000000..304c62fe898e
--- /dev/null
+++ b/README.english.md
@@ -0,0 +1,4 @@
+# Balong-usbdload
+The utility for USB-boot emergency modem chipset Balong V2R7 and V2R11.
+It allows you to load an external loader-emergency flasher via USB-serial port download created modem
+if damaged firmware or an earth fault alarm contact load on the modem card.
diff --git a/helpmessages_english.txt b/helpmessages_english.txt
new file mode 100644
index 000000000000..d7b4afad42ea
--- /dev/null
+++ b/helpmessages_english.txt
@@ -0,0 +1,80 @@
+[ The following has been translated from Russian by http://http://translate.google.com/ ]
+
+* Output of the command 'balong-usbdload':
+
+== %< ==
+
+Emergency USB-loader Balong-chipset, version 2.02, (c) forth32, 2015
+ - Not specified file name to download
+
+== >% ==
+
+* Output of the command 'balong-usbdload -h:
+
+== %< ==
+
+The tool is designed for emergency USB-boot devices Chipeta Balong V7
+
+./balong-usbdload [options] <file name to download>
+
+ The valid keys are:
+
+-p <tty> - serial port for communication with the loader (by default, /dev/ttyUSB0)
+-f - usbloader only ship to the fastboot (without running Linux)
+-b - similar to -f, in addition to disable checking of defect blocks when erasing
+-t <file> - take the partition table of the specified file
+-m - show bootloader partition table and exit
+-s n - set the flag for the file section n (the key can be specified multiple times)
+-c - not automatically erase the patch sections
+
+== >% ==
+
+* Output of the command 'loader-patch':
+
+== %< ==
+
+automatic modification program downloaders Balong V7, (c) forth32
+ - Not specified file name to download
+ - To specify the -h key tips
+
+== >% ==
+
+* Output of the command 'loader-patch -h':
+
+== %< ==
+
+The program for automatic patch downloaders Balong V7 platforms
+
+./loader-patch [options] <file loader usbloader>
+
+ The valid keys are:
+
+-o file - the output file name. By default, only the possibility of verification of the patch
+-b - add a patch that disables checking of defective units
+
+== >% ==
+
+* Output of the command 'ptable-injector':
+
+== %< ==
+
+- Not Specified loader file name
+
+== >% ==
+
+* Output of the command 'ptable-injector -h':
+
+== %< ==
+
+Utility to replace the partition table in the loader usbloader
+ The modem must be in the fastboot mode
+
+./ptable-injector [options] <file name usbloader>
+
+ The valid keys are:
+
+-m - show current map sections in usbloader
+-x - extract the current map file in ptable.bin
+-r <file> - replace sections of the map to the map of the specified file
+
+== >% ==