summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustanoobcoder2020-10-23 08:54:26 +0700
committerjustanoobcoder2020-10-23 08:54:26 +0700
commit0e42f80085c9616e8781a1ffca0e71a4dc867278 (patch)
tree4614c4909398d938bb0685021d639f93cde19508
downloadaur-0e42f80085c9616e8781a1ffca0e71a4dc867278.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f37a454bca7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bamboo-ibus-git
+ pkgdesc = A Vietnamese IME for IBus
+ pkgver = 0.6.7
+ pkgrel = 1
+ url = https://github.com/BambooEngine/ibus-bamboo
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = go
+ makedepends = libx11
+ makedepends = libxtst
+ depends = ibus
+ conflicts = ibus-bamboo
+ source = git+https://github.com/BambooEngine/ibus-bamboo
+ md5sums = SKIP
+
+pkgname = bamboo-ibus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5a2e8eb988e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Bamboo - A Vietnamese Input method editor
+# Copyright (C) 2018 Luong Thanh Lam <ltlam93@gmail.com>
+
+pkgname=bamboo-ibus-git
+_pkgname=ibus-bamboo
+pkgver=0.6.7
+pkgrel=1
+pkgdesc='A Vietnamese IME for IBus'
+arch=('any')
+license=('GPL3')
+url="https://github.com/BambooEngine/ibus-bamboo"
+conflicts=('ibus-bamboo')
+depends=('ibus')
+makedepends=('git' 'go' 'libx11' 'libxtst')
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "%s" "$(awk -F '=' '/^version/ {print $2}' Makefile)"
+}
+
+build() {
+ cd "$_pkgname"
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}