aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Jacocks2022-12-17 00:32:21 -0500
committerAlexander Jacocks2022-12-17 00:32:21 -0500
commit78e68cfb95819c31f355174aea6e6865aae99e0f (patch)
tree43254e7ddd67b2e6d4f75a04bfb4658af8d6c06b
parent94161a9201529dffc7826e884af2d5757d7546e0 (diff)
downloadaur-78e68cfb95819c31f355174aea6e6865aae99e0f.tar.gz
add UTF-8 patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--TreeSupport.cpp.patch16
3 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7abdb2cfa0b3..134473adb230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bambustudio-git
pkgdesc = PC Software for BambuLab's 3D printers
- pkgver = 1.2.0.9.300.gb77682c
+ pkgver = 01.04.00.17.0.gd472eb7a
pkgrel = 1
url = https://github.com/bambulab/BambuStudio
arch = x86_64
@@ -26,10 +26,12 @@ pkgbase = bambustudio-git
conflicts = BambuStudio
source = git+https://github.com/bambulab/BambuStudio.git
source = BambuStudio.cpp.patch
+ source = TreeSupport.cpp.patch
source = CMakeLists.txt.patch
source = bambu-studio.sh
sha512sums = SKIP
sha512sums = 419e7ffb8044531a1c78cd191a96c11f719b439afce674f7e31d1d2e0dc57ecc03cea27ab4ad5ee6522606630fd59ac1745b9a1b787db14893561a4495806117
+ sha512sums = 674fc00a73b2e5997e5f3dcf74299a2ab5dfac5114247f8b6b0c87bf14f289413ec668a39063ef10a557cc2c45ca08e52a7b1714a1f9f69763edf3a7faa1d01c
sha512sums = 8682e3b11271ae09587298f4737b987a589db05e049c3f4699951d710c6263e6016ee2287b050143336b9b24d70d206a1d7c5396bf74a5ccf092af6e1491ff54
sha512sums = e3cb1b072754ae6443fa136fffa263761b5e4e3da5dca1e91b7c4d577daaf01afa0affde04f1355fc404fcd336852db4ce8dc57938833f864346a0b17c12d6d6
diff --git a/PKGBUILD b/PKGBUILD
index b5d629276497..2edc67a60042 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alexander Jacocks <alexander@redhat.com>
pkgname="bambustudio-git"
-pkgver=1.2.0.9.300.gb77682c
+pkgver=01.04.00.17.0.gd472eb7a
pkgrel=1
pkgdesc="PC Software for BambuLab's 3D printers"
arch=('x86_64')
@@ -14,11 +14,13 @@ conflicts=("BambuStudio")
source=(
'git+https://github.com/bambulab/BambuStudio.git'
'BambuStudio.cpp.patch'
+ 'TreeSupport.cpp.patch'
'CMakeLists.txt.patch'
'bambu-studio.sh'
)
sha512sums=('SKIP'
'419e7ffb8044531a1c78cd191a96c11f719b439afce674f7e31d1d2e0dc57ecc03cea27ab4ad5ee6522606630fd59ac1745b9a1b787db14893561a4495806117'
+ '674fc00a73b2e5997e5f3dcf74299a2ab5dfac5114247f8b6b0c87bf14f289413ec668a39063ef10a557cc2c45ca08e52a7b1714a1f9f69763edf3a7faa1d01c'
'8682e3b11271ae09587298f4737b987a589db05e049c3f4699951d710c6263e6016ee2287b050143336b9b24d70d206a1d7c5396bf74a5ccf092af6e1491ff54'
'e3cb1b072754ae6443fa136fffa263761b5e4e3da5dca1e91b7c4d577daaf01afa0affde04f1355fc404fcd336852db4ce8dc57938833f864346a0b17c12d6d6')
@@ -31,6 +33,8 @@ pkgver() {
prepare() {
# fix broken udev install reference
patch -p0 < "$srcdir/CMakeLists.txt.patch"
+ # remove invalid UTF-8 chars
+ patch -p0 < "$srcdir/TreeSupport.cpp.patch"
}
build() {
diff --git a/TreeSupport.cpp.patch b/TreeSupport.cpp.patch
new file mode 100644
index 000000000000..5951fbc990c1
--- /dev/null
+++ b/TreeSupport.cpp.patch
@@ -0,0 +1,16 @@
+--- BambuStudio/src/libslic3r/TreeSupport.cpp.orig 2022-12-15 10:33:19.000000000 -0500
++++ BambuStudio/src/libslic3r/TreeSupport.cpp 2022-12-16 16:16:11.261961293 -0500
+@@ -2057,10 +2057,10 @@
+
+ const Node& node = *p_node;
+ ExPolygon area;
+- // 直接从overhang多边形生成,如果?
++ // 直接从overhang多边形生成,如果?
+ // 1) 是混合支撑里的普通部分,
+- // 2) 启用了顶部接触层?
+- // 3) 是顶部空?
++ // 2) 启用了顶部接触层?
++ // 3) 是顶部空?
+ if (node.type == ePolygon || (top_interface_layers>0 &&node.support_roof_layers_below > 0) || node.distance_to_top<0) {
+ if (node.overhang->contour.size() > 100 || node.overhang->holes.size()>1)
+ area = *node.overhang;