summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2016-08-04 09:20:19 +0200
committerChristian Krause2016-08-04 09:20:19 +0200
commit4fa2cb7278b72c8a2207a519c4390588c98c1c5c (patch)
tree3fbaa1f63fe5014fc4405d854b705d18927cf48d
parent3cd4e0c0b06585f0960d46df28e53679dd7401e7 (diff)
downloadaur-4fa2cb7278b72c8a2207a519c4390588c98c1c5c.tar.gz
bamtools-2.4.0-2
use explicit c++ standard
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5e8d7aa38f4..e3f0041820c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Aug 4 07:19:49 UTC 2016
pkgbase = bamtools
pkgdesc = C++ API & command-line toolkit for working with BAM data
pkgver = 2.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pezmaster31/bamtools
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 832ed812b941..ae6fa677e152 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=bamtools
pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="C++ API & command-line toolkit for working with BAM data"
arch=('x86_64' 'i686')
url="https://github.com/pezmaster31/bamtools"
license=('custom')
depends=('gcc-libs' 'zlib')
makedepends=('cmake')
-source=($pkgname-$pkgver.tar.gz::https://github.com/pezmaster31/$pkgname/archive/v$pkgver.tar.gz
+source=($pkgname-$pkgver.tar.gz::https://github.com/pezmaster31/bamtools/archive/v$pkgver.tar.gz
lib-destination.patch::https://github.com/pezmaster31/bamtools/pull/82.patch)
md5sums=('6139d00c1b1fe88fe15d094d8a74d8b9'
'fb81680ab082f3214dfbd409505e7fc3')
@@ -19,6 +19,9 @@ prepare() {
patch -Np1 -i $srcdir/lib-destination.patch
+ sed -e '/set( CMAKE_BUILD_TYPE Release )/a set( CMAKE_CXX_FLAGS_RELEASE "-std=c++98 ${CMAKE_CXX_FLAGS_RELEASE}" )' \
+ -i CMakeLists.txt
+
mkdir -p build
}