summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2022-06-27 08:31:04 +0200
committerOleksandr Natalenko2022-06-27 08:31:04 +0200
commit33a0bc9679116d70586753c201d223860901a7ed (patch)
tree5e60423e89da5bd027282927518122bd596757d3
parent57e75bb475b22e8b010e387ee4b4a47dc0155b4b (diff)
downloadaur-33a0bc9679116d70586753c201d223860901a7ed.tar.gz
bump version to 2.0.11
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD36
2 files changed, 11 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb580608a099..3c188d56a6dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = bandwidthd
pkgdesc = Daemon for graphing traffic of subnet machines
- pkgver = 2.0.8
+ pkgver = 2.0.11
pkgrel = 1
epoch = 1
url = https://gitlab.com/post-factum/bandwidthd
arch = x86_64
license = GPL
+ makedepends = meson
depends = sqlite
depends = libpcap
depends = libpng
@@ -13,7 +14,7 @@ pkgbase = bandwidthd
depends = nginx
backup = etc/bandwidthd/bandwidthd.conf
backup = etc/bandwidthd/bandwidthd-webui.conf
- source = bandwidthd-2.0.8.tar.bz2::https://gitlab.com/post-factum/bandwidthd/-/archive/v2.0.8/bandwidthd-v2.0.8.tar.bz2
- sha256sums = 639a3ae5bed15aac9b2de8495bc8c9ca91bf5bd70dc114dfef1e43af043e9608
+ source = bandwidthd-2.0.11.tar.bz2::https://gitlab.com/post-factum/bandwidthd/-/archive/v2.0.11/bandwidthd-v2.0.11.tar.bz2
+ sha256sums = 0c7ff96233a778df74b99e029c86d0e1ba2172def0777f89e74d227eb53bd5fc
pkgname = bandwidthd
diff --git a/PKGBUILD b/PKGBUILD
index 12d7a8068158..2c32bc10e203 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bandwidthd
_repouser=post-factum
_reponame=bandwidthd
-pkgver=2.0.8
+pkgver=2.0.11
pkgrel=1
epoch=1
pkgdesc="Daemon for graphing traffic of subnet machines"
@@ -11,46 +11,24 @@ arch=(x86_64)
url="https://gitlab.com/post-factum/bandwidthd"
license=(GPL)
depends=(sqlite libpcap libpng gd nginx)
-
+makedepends=(meson)
source=(${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/${_repouser}/${_reponame}/-/archive/v${pkgver}/${_reponame}-v${pkgver}.tar.bz2)
-sha256sums=('639a3ae5bed15aac9b2de8495bc8c9ca91bf5bd70dc114dfef1e43af043e9608')
+sha256sums=('0c7ff96233a778df74b99e029c86d0e1ba2172def0777f89e74d227eb53bd5fc')
backup=('etc/bandwidthd/bandwidthd.conf'
'etc/bandwidthd/bandwidthd-webui.conf')
-prepare () {
- cd "${_reponame}-v${pkgver}"
-
- autoreconf
-
- CFLAGS="-std=gnu89 ${CFLAGS}" ./configure \
- --prefix=/usr \
- --sysconfdir=/etc/bandwidthd \
- --localstatedir=/var/lib \
- --without-x
-}
-
build() {
cd "${_reponame}-v${pkgver}"
- make -j1
+ arch-meson . build
+
+ meson compile -C build
}
package() {
cd "${_reponame}-v${pkgver}"
- install -dm700 "${pkgdir}/var/lib/bandwidthd"
-
- make DESTDIR="${pkgdir}" install
-
- install -Dm644 "etc/bandwidthd.service" -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm644 "etc/bandwidthd-webui.service" -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm644 "etc/bandwidthd-webui.conf" -t "${pkgdir}/etc/bandwidthd"
- install -Dm644 "etc/bandwidthd-rotate.timer" -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm644 "etc/bandwidthd-rotate.service" -t "${pkgdir}/usr/lib/systemd/system"
- install -Dm644 "etc/bandwidthd.sysusers" "${pkgdir}/usr/lib/sysusers.d/bandwidthd.conf"
- install -Dm644 "etc/bandwidthd.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/bandwidthd.conf"
+ meson install -C build --destdir "${pkgdir}"
}
-
-# vim: set tabstop=4:softtabstop=4:shiftwidth=4:noexpandtab