summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2020-07-26 01:05:59 +0200
committerOleksandr Natalenko2020-07-26 01:06:10 +0200
commitac19b2a08a7b3f933849fd11c6fa22c15549b2d3 (patch)
tree3406df59a40366e5b45a0a741417c73838d9fc38
parent954b6b156e6fdcbadf5b6149253ef12d43a84677 (diff)
downloadaur-ac19b2a08a7b3f933849fd11c6fa22c15549b2d3.tar.gz
fix externs
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO4
-rw-r--r--06-bandwidthd-externs.patch89
-rw-r--r--PKGBUILD5
3 files changed, 96 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 158d25c09c58..59f894faa6b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bandwidthd
pkgdesc = Daemon for graphing traffic of subnet machines
pkgver = 2.0.2.r1.0307fbba56
- pkgrel = 10
+ pkgrel = 11
epoch = 1
url = https://github.com/neatbasis/bandwidthd
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = bandwidthd
source = 03-bandwidthd-subnet-reporting.patch
source = 04-bandwidthd-misc.patch
source = 05-bandwidthd-pidfile.patch
+ source = 06-bandwidthd-externs.patch
source = bandwidthd.service
source = bandwidthd-webui.service
source = bandwidthd-webui.conf
@@ -32,6 +33,7 @@ pkgbase = bandwidthd
sha256sums = 88c38a18b7bda6f3496dda3030ba118f8c461447dea426c13245099ae37a6d86
sha256sums = be5fa230311258f14d4af6a00496443bfbc1a148a77f237bb4a0b663947e090a
sha256sums = fc38a5623e66d82dec2efd28d2729e76e8f3b6056fb2bc2462a1ea1549f68807
+ sha256sums = 51788ac70e44ca20706014302466cee7d70e19ad70faba52e3a54fb5c2c3c2a2
sha256sums = 9c1cd09515073875438dc75fa0919cf6654dd1bd6398dbbb3772b990f515e71f
sha256sums = 4e9f265d8cb2f23a5458afae61a8f88377ddc9ee31fa42b38a4062f0ffe426e1
sha256sums = cd7b1ffff5dd9490ab69d777e459d79c229d5fef2e71a811df29f6c11e6acde4
diff --git a/06-bandwidthd-externs.patch b/06-bandwidthd-externs.patch
new file mode 100644
index 000000000000..436dee2202d3
--- /dev/null
+++ b/06-bandwidthd-externs.patch
@@ -0,0 +1,89 @@
+Common subdirectories: bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/autom4te.cache and bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/autom4te.cache
+diff --color -u bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/bandwidthd.h bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/bandwidthd.h
+--- bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/bandwidthd.h 2019-03-27 20:05:31.000000000 +0100
++++ bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/bandwidthd.h 2020-07-26 01:02:59.083501756 +0200
+@@ -138,7 +138,7 @@
+ {
+ uint32_t ip;
+ uint32_t mask;
+- } SubnetTable[SUBNET_NUM];
++ };
+
+ struct Statistics
+ {
+@@ -162,7 +162,7 @@
+ uint32_t ip; // Host byte order
+ struct Statistics Send;
+ struct Statistics Receive;
+- } IpTable[IP_NUM];
++ };
+
+ struct SummaryData
+ {
+diff --color -u bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/conf.y bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/conf.y
+--- bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/conf.y 2019-03-27 20:05:31.000000000 +0100
++++ bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/conf.y 2020-07-26 01:03:49.061196876 +0200
+@@ -13,9 +13,10 @@
+
+ extern unsigned int SubnetCount;
+ extern unsigned int NotSubnetCount;
+-extern struct SubnetData SubnetTable[];
++extern struct SubnetData SubnetTable[SUBNET_NUM];
+ extern struct SubnetData NotSubnetTable[];
+ extern struct config config;
++extern struct IPData IpTable[IP_NUM];
+
+ int bdconfig_lex(void);
+ int LineNo = 1;
+Common subdirectories: bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/etc and bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/etc
+Common subdirectories: bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/extensions and bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/extensions
+diff --color -u bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/extensions.c bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/extensions.c
+--- bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/extensions.c 2019-03-27 20:05:31.000000000 +0100
++++ bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/extensions.c 2020-07-26 01:04:11.524995125 +0200
+@@ -5,6 +5,8 @@
+ #include <unistd.h>
+
+ extern struct config config;
++extern struct SubnetData SubnetTable[SUBNET_NUM];
++extern struct IPData IpTable[IP_NUM];
+
+ static char *execute_extension(char * filename);
+
+diff --color -u bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/graph.c bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/graph.c
+--- bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/graph.c 2019-03-27 20:05:31.000000000 +0100
++++ bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/graph.c 2020-07-26 01:03:31.484168544 +0200
+@@ -20,6 +20,8 @@
+
+ extern unsigned int SubnetCount;
+ extern struct config config;
++extern struct SubnetData SubnetTable[SUBNET_NUM];
++extern struct IPData IpTable[IP_NUM];
+
+ jmp_buf dnsjump;
+
+Common subdirectories: bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/htdocs and bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/htdocs
+diff --color -u bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/pgsql.c bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/pgsql.c
+--- bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/pgsql.c 2019-03-27 20:05:31.000000000 +0100
++++ bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/pgsql.c 2020-07-26 01:04:02.908148428 +0200
+@@ -5,6 +5,8 @@
+ extern unsigned int IpCount;
+ extern struct Broadcast *Broadcasts;
+ extern time_t ProgramStart;
++extern struct SubnetData SubnetTable[SUBNET_NUM];
++extern struct IPData IpTable[IP_NUM];
+
+ jmp_buf pgsqljmp;
+
+Common subdirectories: bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/phphtdocs and bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/phphtdocs
+diff --color -u bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/sqlite.c bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/sqlite.c
+--- bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef~/sqlite.c 2019-03-27 20:05:31.000000000 +0100
++++ bandwidthd-0307fbba56a39a6e65ebadf488ad87979c64fdef/sqlite.c 2020-07-26 01:04:07.021566388 +0200
+@@ -3,6 +3,8 @@
+ extern struct config config;
+ extern unsigned int IpCount;
+ extern time_t ProgramStart;
++extern struct SubnetData SubnetTable[SUBNET_NUM];
++extern struct IPData IpTable[IP_NUM];
+
+ #ifdef HAVE_LIBSQLITE3
+
diff --git a/PKGBUILD b/PKGBUILD
index bee7c022febd..b236f5c711ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _repouser=neatbasis
_reponame=bandwidthd
_rev=0307fbba56a39a6e65ebadf488ad87979c64fdef
pkgver=2.0.2.r1.${_rev:0:10}
-pkgrel=10
+pkgrel=11
epoch=1
pkgdesc="Daemon for graphing traffic of subnet machines"
arch=(x86_64)
@@ -19,6 +19,7 @@ source=(${pkgname}-${pkgver}.tar.gz::https://github.com/${_repouser}/${_reponame
03-bandwidthd-subnet-reporting.patch
04-bandwidthd-misc.patch
05-bandwidthd-pidfile.patch
+ 06-bandwidthd-externs.patch
bandwidthd.service
bandwidthd-webui.service
bandwidthd-webui.conf
@@ -33,6 +34,7 @@ sha256sums=('7e8ebf7e2eeb5266af904a8f7188b11d5a13ebb0343022c2a118b86f48a952e4'
'88c38a18b7bda6f3496dda3030ba118f8c461447dea426c13245099ae37a6d86'
'be5fa230311258f14d4af6a00496443bfbc1a148a77f237bb4a0b663947e090a'
'fc38a5623e66d82dec2efd28d2729e76e8f3b6056fb2bc2462a1ea1549f68807'
+ '51788ac70e44ca20706014302466cee7d70e19ad70faba52e3a54fb5c2c3c2a2'
'9c1cd09515073875438dc75fa0919cf6654dd1bd6398dbbb3772b990f515e71f'
'4e9f265d8cb2f23a5458afae61a8f88377ddc9ee31fa42b38a4062f0ffe426e1'
'cd7b1ffff5dd9490ab69d777e459d79c229d5fef2e71a811df29f6c11e6acde4'
@@ -52,6 +54,7 @@ prepare () {
patch -Np1 -i ../03-bandwidthd-subnet-reporting.patch
patch -Np1 -i ../04-bandwidthd-misc.patch
patch -Np1 -i ../05-bandwidthd-pidfile.patch
+ patch -Np1 -i ../06-bandwidthd-externs.patch
sed -i 's|EXTRA_VERSION=".IPv6"|EXTRA_VERSION=".'${_rev:0:10}'"|' configure.in