summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYacob Zitouni2021-03-12 17:05:32 +0100
committerYacob Zitouni2021-03-12 17:05:32 +0100
commit5431b83095461c14cd78d11a8f44028da80f6f4a (patch)
treed30ec530ce7f05d143b07e0fd908787e69d1cf65
downloadaur-5431b83095461c14cd78d11a8f44028da80f6f4a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d60ea3ac0947
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bannertool
+ pkgdesc = A tool for creating 3DS banners
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/Steveice10/bannertool/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source = bannertool::git+https://github.com/Steveice10/bannertool.git#tag=1.2.0
+ source = buildtools::git+https://github.com/Steveice10/buildtools.git#commit=4524b3a
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = bannertool
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5ee495eac62
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Yacob Zitouni <yacob.zitouni@gmail.com>
+pkgname=('bannertool')
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="A tool for creating 3DS banners"
+arch=('i686' 'x86_64')
+url="https://github.com/Steveice10/bannertool/"
+license=('MIT')
+sha256sums=('SKIP' 'SKIP')
+
+source=("$pkgname::git+https://github.com/Steveice10/bannertool.git#tag=1.2.0"
+ "buildtools::git+https://github.com/Steveice10/buildtools.git#commit=4524b3a")
+
+
+prepare() {
+ cd "$pkgname"
+ git submodule init
+ git config submodule.buildtools.url $srcdir/buildtools
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/$pkgname/"
+ make
+}
+
+package() {
+ install -D "$srcdir/$pkgname/output/linux-$CARCH/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}