summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWillem Mulder2017-01-15 21:32:30 +0100
committerWillem Mulder2017-01-15 21:32:30 +0100
commit01df519c5b06020473164dba22ae20f2bf4c2fba (patch)
tree882dc864b43145404d9d5132ce5d876b48313530
downloadaur-01df519c5b06020473164dba22ae20f2bf4c2fba.tar.gz
Import package from aur-archive and improve it:
- Specify all listed dependencies in either of the depends fields - Enable checks - Explicitly state which extensions to build - Specify vendor build ID - Specify path to MCS
-rw-r--r--.SRCINFO45
-rw-r--r--.gitattributes1
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD87
4 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..70c7a1e6e10f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,45 @@
+# Generated by mksrcinfo v8
+# Sun Jan 15 20:27:08 UTC 2017
+pkgbase = banshee-community-extensions
+ pkgdesc = Banshee Community Extensions is a repository and project for extensions to the Banshee media player that are community contributed and maintained.
+ pkgver = 2.4.0
+ pkgrel = 2
+ url = http://banshee.fm/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = lsb-release
+ makedepends = gnome-doc-utils>=0.17.3
+ makedepends = libappindicator-sharp
+ makedepends = notify-sharp
+ makedepends = fftw>=3
+ makedepends = libsamplerate
+ makedepends = lirc
+ makedepends = empathy>=2.27.91
+ makedepends = telepathy-gabble>=0.9
+ makedepends = telepathy-mission-control>=5.3.1
+ depends = banshee>=2.4.0
+ depends = mono>=2.4.3
+ depends = sqlite>=3.4
+ depends = gstreamer0.10>=0.10.26
+ depends = gtk-sharp-2>=2.12.10
+ depends = dbus-sharp>=0.7
+ depends = dbus-sharp-glib>=0.5
+ depends = mono-addins>=0.6.2
+ depends = taglib-sharp>=2.0.3.7
+ optdepends = libappindicator-sharp: For the AppIndicator extension
+ optdepends = notify-sharp: For the AppIndicator extension
+ optdepends = fftw>=3: For the LastFM Fingerprint and Mirage extensions
+ optdepends = libsamplerate: For the LastFM Fingerprint and Mirage extensions
+ optdepends = gstreamer0.10-base>=0.10.15: For the LastFM Fingerprint and Mirage extensions
+ optdepends = gstreamer0.10-base-plugins>=0.10.15: For the LastFM Fingerprint and Mirage extensions
+ optdepends = lcdproc: For the LCDproc extension
+ optdepends = lirc: For the LIRC extension
+ optdepends = empathy>=2.27.91: For the Telepathy extension
+ optdepends = telepathy-gabble>=0.9: For the Telepathy extension
+ optdepends = telepathy-mission-control>=5.3.1: For the Telepathy extension
+ source = http://download.banshee.fm/banshee-community-extensions/2.4.0/banshee-community-extensions-2.4.0.tar.bz2
+ sha256sums = 6f20404de80090bb5d88a57c043e876a192f480ac3488ce7697344f1447d48b3
+
+pkgname = banshee-community-extensions
+
diff --git a/.gitattributes b/.gitattributes
new file mode 100644
index 000000000000..08c7cb3413a1
--- /dev/null
+++ b/.gitattributes
@@ -0,0 +1 @@
+.SRCINFO -whitespace
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d2b754add8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitattributes
+!.gitignore
+!/*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1cb6ef430b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,87 @@
+# Maintainer: Willem Mulder <14mRh4X0r@gmail.com>
+pkgname=banshee-community-extensions
+pkgver=2.4.0
+pkgrel=2
+pkgdesc="Banshee Community Extensions is a repository and project for extensions to the Banshee \
+ media player that are community contributed and maintained."
+arch=('i686' 'x86_64')
+url="http://banshee.fm/"
+license=('GPL2')
+# Banshee and its dependencies (from https://github.com/GNOME/banshee/tree/stable-2.4)
+depends=('banshee>=2.4.0' 'mono>=2.4.3' 'sqlite>=3.4' 'gstreamer0.10>=0.10.26'
+ 'gtk-sharp-2>=2.12.10' 'dbus-sharp>=0.7' 'dbus-sharp-glib>=0.5' 'mono-addins>=0.6.2'
+ 'taglib-sharp>=2.0.3.7')
+makedepends=('lsb-release' 'gnome-doc-utils>=0.17.3'
+ # AppIndicator
+ 'libappindicator-sharp' 'notify-sharp'
+ # LastfmFingerprint and Mirage
+ 'fftw>=3' 'libsamplerate'
+ # LIRC
+ 'lirc'
+ # Telepathy
+ 'empathy>=2.27.91' 'telepathy-gabble>=0.9' 'telepathy-mission-control>=5.3.1')
+checkdepends=() # nunit is included in mono
+optdepends=(#'banshee-youtube: for banshee with youtube extension enabled'
+ 'libappindicator-sharp: For the AppIndicator extension'
+ 'notify-sharp: For the AppIndicator extension'
+ 'fftw>=3: For the LastFM Fingerprint and Mirage extensions'
+ 'libsamplerate: For the LastFM Fingerprint and Mirage extensions'
+ 'gstreamer0.10-base>=0.10.15: For the LastFM Fingerprint and Mirage extensions'
+ 'gstreamer0.10-base-plugins>=0.10.15: For the LastFM Fingerprint and Mirage extensions'
+ 'lcdproc: For the LCDproc extension'
+ 'lirc: For the LIRC extension'
+ 'empathy>=2.27.91: For the Telepathy extension'
+ 'telepathy-gabble>=0.9: For the Telepathy extension'
+ 'telepathy-mission-control>=5.3.1: For the Telepathy extension')
+source=(http://download.banshee.fm/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2)
+sha256sums=('6f20404de80090bb5d88a57c043e876a192f480ac3488ce7697344f1447d48b3')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ # Flag rationale:
+ # - Packages for ClutterFlow are not available
+ # - OpenVP fails checks
+ # - Packages for Zeitgeist are not available
+ ./configure --prefix=/usr \
+ --with-vendor-build-id="$(lsb_release -ds | sed -r 's/^"(.*)"$/\1/')" \
+ --enable-gnome \
+ --enable-schemas-install \
+ --enable-alarmclock \
+ --enable-albumartwriter \
+ --enable-ampache \
+ --enable-appindicator \
+ --enable-awn \
+ --disable-clutterflow \
+ --enable-coverwallpaper \
+ --enable-duplicatesongdetector \
+ --enable-foldersync \
+ --enable-jamendo \
+ --enable-karaoke \
+ --enable-lastfmfingerprint \
+ --enable-lcd \
+ --enable-lirc \
+ --enable-lyrics \
+ --enable-liveradio \
+ --enable-magnatune \
+ --enable-mirage \
+ --disable-openvp \
+ --enable-radiostationfetcher \
+ --enable-randombylastfm \
+ --enable-streamrecorder \
+ --enable-telepathy \
+ --disable-zeitgeistdataprovider \
+ --enable-tests \
+ --disable-shave \
+ DMCS=/usr/bin/mcs
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR=$pkgdir/ install
+}
+
+check() {
+ cd ${pkgname}-${pkgver}
+ make check
+}