summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorΝικόλαος Κυριάκος Φυτίλης2017-11-07 19:37:45 +0200
committerΝικόλαος Κυριάκος Φυτίλης2017-11-07 19:37:45 +0200
commit7c5e182baf3218250c98a85ebb1d8fd840091eda (patch)
tree6ac051a0e049ca379592db4ca914545dcbab9d75
parentf793cf44f599c0d771bbbe84c0c1c5fa63d4e5e6 (diff)
downloadaur-7c5e182baf3218250c98a85ebb1d8fd840091eda.tar.gz
aur is silly and so am i
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 227bd960ab9e..4bcb3bcfc35d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -30,5 +30,5 @@ pkgbase = banshee
source = git+https://github.com/arfbtwn/banshee.git
md5sums = SKIP
-pkgname = banshee
+pkgname = banshee-git
diff --git a/PKGBUILD b/PKGBUILD
index b0828c4d9f15..6ebec262ea16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Νικόλαος Κυριάκος Φυτίλης <n-fit@live.com>
-pkgname=banshee
+pkgname=banshee-git
+pkgbase=banshee
pkgver=2.9.1.r327.gd6f7b6294
pkgrel=1
pkgdesc="Music management and playback for GNOME (fork by arfbtwn)"
@@ -18,12 +19,12 @@ source=(git+https://github.com/arfbtwn/banshee.git)
md5sums=(SKIP)
pkgver() {
- cd "$pkgname"
+ cd "$_pkgbase"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $pkgname
+ cd $_pkgbase
git checkout feature/mediapanel
# autoreconf -fvi
NOCONFIGURE=1 ./autogen.sh
@@ -54,7 +55,7 @@ build() {
mkdir -p "$MONO_SHARED_DIR"
export LIBGPODSHARP='-r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-3.0/pango-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-3.0/atk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-3.0/gdk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-3.0/gtk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-3.0/glib-sharp.dll'
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgbase"
sed 's/CollectionExtensions/Hyena.Collections.CollectionExtensions/g' -i src/Core/Banshee.Services/Banshee.Preferences/Collection.cs
make
@@ -64,8 +65,8 @@ package() {
export MONO_SHARED_DIR="$srcdir/.wabi"
mkdir -p "$MONO_SHARED_DIR"
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$_pkgbase"
make DESTDIR="$pkgdir" install
- install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$_pkgbase/COPYING"
}