summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRagnar Groot Koerkamp2021-10-23 00:44:07 +0200
committerRagnar Groot Koerkamp2021-10-23 00:44:07 +0200
commit717a7d190b8951fd768e723c3dcf2c8ac0a2eaca (patch)
tree857e1db48e643bb97f6f912211c37e42273c6ba4
parente1ac0177636774fa8eb2852e30568505525441fe (diff)
downloadaur-717a7d190b8951fd768e723c3dcf2c8ac0a2eaca.tar.gz
Change cp to rsync
-rw-r--r--PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a3b0e77bd68..a3a88103766b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,36 +9,35 @@ url="https://github.com/RagnarGrootKoerkamp/BAPCtools"
license=('GPL 3.0')
depends=('python3' 'python-yaml' 'python-colorama' 'python-argcomplete' 'python-ruamel-yaml')
optdepends=('gcc: for compiling c++ sources',
- 'clang: for compiling c++ sources',
- 'pypy3: for running python submissions with pypy',
- 'python2: for running python2 submissions',
- 'pypy: for running python2 submissions with pypy',
- 'jdk11-openjdk: for running java submissions',
- 'kotlin: for running kotlin submissions',
- 'texlive-core: for building problem statements',
- 'texlive-latexextra: for building problem statements',
- 'texlive-pictures: for building problem statements',
- 'texlive-science: for building problem statements',
- 'ghostscript: for LaTeX figures',
- 'asymptote: for visualizations'
- )
+ 'clang: for compiling c++ sources',
+ 'pypy3: for running python submissions with pypy',
+ 'python2: for running python2 submissions',
+ 'pypy: for running python2 submissions with pypy',
+ 'jdk11-openjdk: for running java submissions',
+ 'kotlin: for running kotlin submissions',
+ 'texlive-core: for building problem statements',
+ 'texlive-latexextra: for building problem statements',
+ 'texlive-pictures: for building problem statements',
+ 'texlive-science: for building problem statements',
+ 'ghostscript: for LaTeX figures',
+ 'asymptote: for visualizations'
+)
makedepends=('git')
source=("${_pkgname}::git+https://github.com/RagnarGrootKoerkamp/BAPCtools")
install=bapctools.install
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/shared/licenses/${_pkgname}/LICENSE"
# Strip large directories to halve the size of the install.
- rm -rf "$srcdir/${_pkgname}/doc/images" "$srcdir/${_pkgname}/test"
mkdir -p "${pkgdir}/usr/share/${_pkgname}"
- cp -r "${srcdir}/${_pkgname}" "${pkgdir}/usr/share/${_pkgname}"
+ rsync -aC --exclude "/test" --exclude "/doc/images" -r "${srcdir}/${_pkgname}" "${pkgdir}/usr/share/${_pkgname}"
# Symlink executable
mkdir -p "${pkgdir}/usr/bin"