summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Kral2023-01-01 19:56:53 +0100
committerVojtech Kral2023-01-01 19:58:19 +0100
commit9352f23ba6fe718bddcbb91cbc74f302f03120f0 (patch)
tree964240cbd4509e12627511f27f3b404f6dddb1e7
downloadaur-9352f23ba6fe718bddcbb91cbc74f302f03120f0.tar.gz
Initial: v1.3.0
-rw-r--r--.SRCINFO13
-rw-r--r--Makefile5
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d12b48aaace8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bard-bin
+ pkgdesc = Creates PDF and HTML songbooks out of easy-to-write Markdown sources.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/vojtechkral/bard
+ arch = x86_64
+ license = Apache-2.0
+ optdepends = texlive-bin: TeX engine (generate PDFs)
+ optdepends = tectonic: Alternative TeX engine (generate PDFs)
+ source = https://github.com/vojtechkral/bard/releases/download/v1.3.0/bard
+ sha256sums = ef418578e37e6255ad2d5a4fdb84f119923cf91ebd808d3a321ec235f61d581f
+
+pkgname = bard-bin
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..fc859a18a193
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,5 @@
+.PHONY: all
+all:
+ makepkg -g
+ makepkg -fc
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5a0c6a4dea5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Vojtech Kral ❬vojtech%kral.pm❭
+
+pkgname=bard-bin
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Creates PDF and HTML songbooks out of easy-to-write Markdown sources. Binary package."
+arch=('x86_64')
+url="https://github.com/vojtechkral/bard"
+license=('Apache-2.0')
+depends=()
+optdepends=('texlive-bin: TeX engine (generate PDFs) '
+ 'tectonic: Alternative TeX engine (generate PDFs) ')
+source=("https://github.com/vojtechkral/bard/releases/download/v${pkgver}/bard")
+sha256sums=('ef418578e37e6255ad2d5a4fdb84f119923cf91ebd808d3a321ec235f61d581f')
+
+package() {
+ install -Dm 755 bard -t "${pkgdir}/usr/bin/"
+}