aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMotorTruck12212024-01-21 06:00:51 -0700
committerMotorTruck12212024-01-21 06:00:51 -0700
commit8cb08c78d677125eb4150e85b45778346ac370fc (patch)
tree98eb64ed07e68f61e52bfa27b854f7c95c68fa87
downloadaur-8cb08c78d677125eb4150e85b45778346ac370fc.tar.gz
Init
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 27 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecae36fdb577
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = bare-server-go
+ pkgdesc = A TOMPHTTP compliant server written in Go
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/ruby-network/bare-server-go
+ arch = x86_64
+ license = AGPL3
+ source = https://github.com/Ruby-Network/bare-server-go/raw/main/bin/bare-server-go
+ sha256sums = SKIP
+
+pkgname = bare-server-go
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..052531fb6c10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: MotorTruck1221 motortruck1221@protonmail.com
+
+pkgname=bare-server-go
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A TOMPHTTP compliant server written in Go"
+url="https://github.com/ruby-network/bare-server-go"
+arch=('x86_64')
+license=('AGPL3')
+# the source is an artifact from the CI
+source=("https://github.com/Ruby-Network/bare-server-go/raw/main/bin/bare-server-go")
+sha256sums=('SKIP')
+package() {
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/bare-server" "${pkgdir}/usr/bin/bare-server-go"
+}