aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormotortruck12212024-02-17 08:12:10 +0000
committermotortruck12212024-02-17 08:12:10 +0000
commitc42b529be65ccc893a0ea98036614a3d767076cd (patch)
treebc549454fc2a1a314017656fa786963aea05d6bb
parent359d0d5d7c8c8a6abcbb7411774dc27f4dac970d (diff)
downloadaur-c42b529be65ccc893a0ea98036614a3d767076cd.tar.gz
Update to 0.0.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--README.md57
3 files changed, 11 insertions, 62 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89beb6c6e8fb..3422118dd7f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = bare-server-go
pkgdesc = A TOMPHTTP compliant server written in Go
- pkgver = 0.0.1
+ pkgver = 0.0.2
pkgrel = 2
- url = https://github.com/ruby-network/bare-server-go
+ url = https://github.com/tomphttp/bare-server-go
arch = x86_64
license = AGPL3
- source = https://github.com/Ruby-Network/bare-server-go/raw/main/bin/bare-server-go
- sha256sums = 7e6f74ff8c091bb5128855360a5afd8c106b937a53e709a1b0fd9969eb1a3ed2
+ source = https://github.com/tomphttp/bare-server-go/raw/main/bin/bare-server-go
+ sha256sums = 1147590f69193251cb4a018d419927233275946c3c3a50b4d5dd42fcbf07423e
pkgname = bare-server-go
diff --git a/PKGBUILD b/PKGBUILD
index d7fbdb16a963..3baeb5346041 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: MotorTruck1221 motortruck1221@protonmail.com
pkgname=bare-server-go
-pkgver=0.0.1
+pkgver=0.0.2
pkgrel=2
pkgdesc="A TOMPHTTP compliant server written in Go"
-url="https://github.com/ruby-network/bare-server-go"
+url="https://github.com/tomphttp/bare-server-go"
arch=('x86_64')
license=('AGPL3')
# the source is an artifact from the CI
-source=("https://github.com/Ruby-Network/bare-server-go/raw/main/bin/bare-server-go")
-sha256sums=('7e6f74ff8c091bb5128855360a5afd8c106b937a53e709a1b0fd9969eb1a3ed2')
+source=("https://github.com/tomphttp/bare-server-go/raw/main/bin/bare-server-go")
+sha256sums=('1147590f69193251cb4a018d419927233275946c3c3a50b4d5dd42fcbf07423e')
package() {
install -d "${pkgdir}/usr/bin"
install -Dm755 "${srcdir}/bare-server-go" "${pkgdir}/usr/bin/bare-server-go"
diff --git a/README.md b/README.md
index f08de6169786..a4e18d55d768 100644
--- a/README.md
+++ b/README.md
@@ -1,61 +1,8 @@
# Bare Server GO
-- This is a complete bare server written in GO that is compliant with the [TompHTTP Server Specifications](https://github.com/tomphttp/specifications)
-
-***NOTE: Unfinished*** *I skimmed the spec and wrote this only in a few hours. There are lots of unimplemented features and bugs. (and it's curtrently not very TOMP compatible)*
## Usage
-### Prerequisites
-
-- [GO](https://golang.org/doc/install)
-
-### Installation
-
-- Clone this repository
-- To build run:
-```bash
-make all
-```
-- To run:
-```bash
-./bare-server-go start
-```
-
-### For more examples of usage see the [exaples](./examples) directory
-
-#### Docker
-
-- To build AND run:
-```bash
-make docker
-```
-
-- To JUST build:
-```bash
-make docker-build
-```
-
-- To JUST run:
-```bash
-make docker-run
-```
-
-#### Docker Compose
-
-- To build AND run:
-```bash
-make docker-compose
-```
-
-- To JUST build:
-```bash
-make docker-compose-build
-```
-
-- To JUST run:
-```bash
-make docker-compose-up
-```
+- See our [examples](./examples/)
## Todo
@@ -64,6 +11,8 @@ make docker-compose-up
- [ ] V3 implementation
- [ ] Websocket Support (V3) - Partial support
- [x] CLI
+- [ ] Tests
+- [ ] Binaries for all platforms
- [ ] Other ways of installing (AUR, Bash, etc.)
- [ ] Other Ways of Handling Routes (net/http, gorilla/mux, etc.) CURRENTLY ONLY SUPPORTS: [chi](https://github.com/go-chi/chi)
- [ ] Installable in your own project