summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit867df49b3986f8422cbb6462982d142dee1cf13e (patch)
treeeba7ce4212e195ec3076c61189181d09bee8c715
downloadaur-867df49b3986f8422cbb6462982d142dee1cf13e.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--bareftp.install16
-rw-r--r--fix.patch13
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0815f0fc8cfe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bareftp
+ pkgdesc = bareFTP a file transfer client supporting the FTP, FTPS and SFTP protocols
+ pkgver = 0.3.11
+ pkgrel = 1
+ url = http://www.bareftp.org/
+ install = bareftp.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool>=0.35
+ makedepends = pkgconfig>=0.9
+ depends = gnome-sharp>=2
+ depends = gnome-icon-theme
+ depends = gnome-keyring-sharp
+ depends = mono>=2
+ source = http://www.bareftp.org/release/bareftp-0.3.11.tar.gz
+ source = fix.patch
+ sha256sums = cafc6cd6f71ee6e6151cadc517349646977d90b372850e194ad505d89aa6682f
+ sha256sums = 2d4a99fe5ff363a7dc97d1abb85fb8f124ee4935801855eef656b0c089c2a5c3
+
+pkgname = bareftp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d42cd22a5c54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
+
+pkgname=bareftp
+pkgver=0.3.11
+pkgrel=1
+pkgdesc="bareFTP a file transfer client supporting the FTP, FTPS and SFTP protocols"
+arch=('i686' 'x86_64')
+url="http://www.bareftp.org/"
+license=('GPL')
+depends=('gnome-sharp>=2' 'gnome-icon-theme' 'gnome-keyring-sharp' 'mono>=2')
+makedepends=('intltool>=0.35' 'pkgconfig>=0.9')
+install=$pkgname.install
+source=(http://www.bareftp.org/release/$pkgname-$pkgver.tar.gz
+ fix.patch)
+sha256sums=('cafc6cd6f71ee6e6151cadc517349646977d90b372850e194ad505d89aa6682f'
+ '2d4a99fe5ff363a7dc97d1abb85fb8f124ee4935801855eef656b0c089c2a5c3')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ export MONO_SHARED_DIR=$(pwd)
+ ./configure --prefix=/usr
+ patch -p1 -i ../fix.patch
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}
+
diff --git a/bareftp.install b/bareftp.install
new file mode 100644
index 000000000000..5ab27a8f1b8e
--- /dev/null
+++ b/bareftp.install
@@ -0,0 +1,16 @@
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+post_install() {
+ echo -n "Updating desktop MIME database..."
+ update-desktop-database -q
+ [ $? -eq 0 ] && echo " done." || echo " FAILED!"
+
+ echo -n "Updating GTK icon cache..."
+ gtk-update-icon-cache -qft /usr/share/icons/hicolor
+ [ $? -eq 0 ] && echo " done." || echo " FAILED!"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..01de040b09d2
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,13 @@
+diff -ru bareftp-0.3.11-old/src/bareFTP.Protocol.Ftp/ftp/ListParser.cs bareftp-0.3.11-new/src/bareFTP.Protocol.Ftp/ftp/ListParser.cs
+--- bareftp-0.3.11-old/src/bareFTP.Protocol.Ftp/ftp/ListParser.cs 2013-12-15 22:28:13.000000000 +0200
++++ bareftp-0.3.11-new/src/bareFTP.Protocol.Ftp/ftp/ListParser.cs 2014-11-08 09:32:47.336869813 +0200
+@@ -22,7 +22,8 @@
+
+ using System;
+ using System.Collections.Generic;
+-using System.Text;z
++using System.Text;
++using System.Globalization;
+ namespace bareFTP.Protocol.Ftp
+ {
+ public class ListParser