summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Spradling2017-05-09 20:54:55 -0400
committerMichael Spradling2017-05-09 20:54:55 -0400
commit1451cab802d7b1bdaadba6de55525e2a5ae983cc (patch)
tree9372d595a4fe2fcd0af30da797f1ba0e75bf7769
parentd84e285e4fe30ed1044cb578db9734a6f9ad404f (diff)
downloadaur-1451cab802d7b1bdaadba6de55525e2a5ae983cc.tar.gz
Workaround for openssl-1.0 problem
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--PKGBUILD.common4
3 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cbf1bc80a9e..0ac6357f4888 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,7 @@ pkgbase = bareos
source = git+https://github.com/bareos/bareos.git#tag=Release/16.2.5
source = PKGBUILD.common
sha256sums = SKIP
- sha256sums = fad5eef1cf2fd6b9802f082bce2803b3b3a0eadb58b5da9afea2484a068e134c
+ sha256sums = c81ae41baccc3b0762506da2539640e66b26e9cb4b9eb0fbe1b21257381b1490
pkgname = bareos-common
pkgdesc = Bareos - Backup Archiving REcovery Open Sourced - Common files
diff --git a/PKGBUILD b/PKGBUILD
index 7588b1875c0c..0e36b54d265d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,4 +26,4 @@ source=("git+https://github.com/bareos/bareos.git#tag=Release/16.2.5"
"PKGBUILD.common")
sha256sums=('SKIP'
- 'fad5eef1cf2fd6b9802f082bce2803b3b3a0eadb58b5da9afea2484a068e134c')
+ 'c81ae41baccc3b0762506da2539640e66b26e9cb4b9eb0fbe1b21257381b1490')
diff --git a/PKGBUILD.common b/PKGBUILD.common
index 9b752287132f..28d3d7ec29f5 100644
--- a/PKGBUILD.common
+++ b/PKGBUILD.common
@@ -65,6 +65,10 @@ prepare() {
}
build() {
+ # bug: openssl 1.0 isue
+ export CFLAGS="${CFLAGS} -L /usr/include/openssl-1.0"
+ export LIBS="${LIBS} -I /usr/include/openssl-1.0"
+
pushd "${_pkgsrc}" &> /dev/null
QMAKE="/usr/bin/qmake-qt4" DISTNAME="debian" ./configure $_configure_args
make DESTDIR="$_instdir" install