summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Spradling2017-08-29 14:42:27 -0400
committerMichael Spradling2017-08-29 14:42:27 -0400
commit9d7cb59fe37844a175217aabcb7c2618b3400fb2 (patch)
tree8571c173952f7e067081fcd183962462740f1002
parent0cc4a6b2bd7cbbd940a313f2938b829b62bbe820 (diff)
downloadaur-9d7cb59fe37844a175217aabcb7c2618b3400fb2.tar.gz
Add openssl 1.0 support
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD2
-rw-r--r--PKGBUILD.common8
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 505a45727e18..619332540766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bareos
pkgdesc = Bareos - Backup Archiving REcovery Open Sourced
pkgver = 16.2.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.bareos.org
arch = i686
arch = x86_64
@@ -15,11 +15,11 @@ pkgbase = bareos
makedepends = libcap
makedepends = python2
makedepends = python
- optdepends = openssl: network encryption between daemons
+ optdepends = openssl-1.0: network encryption between daemons
source = git+https://github.com/bareos/bareos.git#tag=Release/16.2.6
source = PKGBUILD.common
md5sums = SKIP
- md5sums = 408330e61eba6a1c2add1eeea308dc25
+ md5sums = e3ffabfe93e957649d21ea07f1e25465
pkgname = bareos-common
pkgdesc = Bareos - Backup Archiving REcovery Open Sourced - Common files
@@ -125,7 +125,7 @@ pkgname = bareos-storage
pkgdesc = Bareos - Backup Archiving REcovery Open Sourced - Storage daemon
install = bareos-storage.install
depends = bareos-common=16.2.6
- optdepends = openssl: network encryption between daemons
+ optdepends = openssl-1.0: network encryption between daemons
optdepends = lzo2: LZO compression for Storage Daemon
backup = etc/bareos/tray-monitor.d/storage/StorageDaemon-local.conf
backup = etc/bareos/bareos-sd.d/storage/bareos-sd.conf
diff --git a/PKGBUILD b/PKGBUILD
index c40470ce826d..456fd9510f49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,4 +26,4 @@ source=("git+https://github.com/bareos/bareos.git#tag=Release/16.2.6"
"PKGBUILD.common")
md5sums=('SKIP'
- '408330e61eba6a1c2add1eeea308dc25')
+ 'e3ffabfe93e957649d21ea07f1e25465')
diff --git a/PKGBUILD.common b/PKGBUILD.common
index 02c164115574..ab04645732f9 100644
--- a/PKGBUILD.common
+++ b/PKGBUILD.common
@@ -3,14 +3,14 @@
pkgver=16.2.6
_pkgver=16.2.6
-pkgrel=1
+pkgrel=2
arch=(i686 x86_64)
groups=('bareos')
pkgdesc="Bareos - Backup Archiving REcovery Open Sourced"
url="http://www.bareos.org"
license=('AGPL3')
makedepends=('sqlite3' 'libmariadbclient' 'postgresql-libs' 'lzo' 'acl' 'libcap' 'python2' 'python')
-optdepends=('openssl: network encryption between daemons')
+optdepends=('openssl-1.0: network encryption between daemons')
_instdir="${startdir}/install"
_pkgsrc="${startdir}/src/bareos"
@@ -65,6 +65,10 @@ prepare() {
}
build() {
+ # bug: openssl 1.0 isue
+ export CFLAGS="${CFLAGS} -L /usr/include/openssl-1.0"
+ export LIBS="${LIBS} -I /usr/include/openssl-1.0"
+
pushd "${_pkgsrc}" &> /dev/null
QMAKE="/usr/bin/qmake-qt4" DISTNAME="debian" ./configure $_configure_args
make DESTDIR="$_instdir" install