summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Spradling2018-06-20 19:49:38 +0000
committerMichael Spradling2018-06-20 19:49:38 +0000
commitcd4ed2c0b02fe5a1e9ae69892beb62a21f25b768 (patch)
tree31fa6180fa1c9408fcaec91eafbc4c7c15697e01
parentede71db441711ad2ac9ec31e93e3785c7fa7ff85 (diff)
downloadaur-cd4ed2c0b02fe5a1e9ae69892beb62a21f25b768.tar.gz
Fixed for lint
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 637f3b2638b1..7f112f0621c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bareos
pkgdesc = Bareos - Backup Archiving REcovery Open Sourced
pkgver = 17.2.5
- pkgrel = 3
+ pkgrel = 4
url = http://www.bareos.org
arch = i686
arch = x86_64
@@ -12,6 +12,7 @@ pkgbase = bareos
makedepends = libmariadbclient
makedepends = postgresql-libs
makedepends = sqlite3
+ makedepends = python2
source = git+https://github.com/bareos/bareos.git#tag=Release/17.2.5
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ce5a735b5aa8..a238d50f3fc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,13 +22,13 @@ pkgname=("${pkgbase}-common"
"${pkgbase}-storage-python-plugin")
pkgver=17.2.5
-pkgrel=3
+pkgrel=4
arch=(i686 x86_64 armv7h aarch64)
groups=('bareos')
pkgdesc="Bareos - Backup Archiving REcovery Open Sourced"
url="http://www.bareos.org"
license=('AGPL3')
-makedepends=('libmariadbclient' 'postgresql-libs' 'sqlite3')
+makedepends=('libmariadbclient' 'postgresql-libs' 'sqlite3' 'python2')
source=("git+https://github.com/bareos/bareos.git#tag=Release/$pkgver")
md5sums=('SKIP')
@@ -263,7 +263,7 @@ package_bareos-director() {
usr/share/bareos/config/bareos-dir.d/fileset/Catalog.conf \
usr/share/bareos/config/bareos-dir.d/fileset/LinuxAll.conf \
usr/share/bareos/config/bareos-dir.d/fileset/SelfTest.conf \
- "usr/share/bareos/config/bareos-dir.d/fileset/Windows All Drives.conf" \
+ usr/share/bareos/config/bareos-dir.d/fileset/Windows\ All\ Drives.conf \
usr/share/bareos/config/bareos-dir.d/job/backup-bareos-fd.conf \
usr/share/bareos/config/bareos-dir.d/job/BackupCatalog.conf \
usr/share/bareos/config/bareos-dir.d/job/RestoreFiles.conf \
@@ -282,7 +282,9 @@ package_bareos-director() {
usr/share/man/man8/bareos-dir.8.gz \
usr/share/man/man8/bareos.8.gz \
; do
- _cp "$srcdir/install/$f" "$pkgdir/$f"
+ # pacman LINT tool currently does not like spaces
+ space_removal=`echo $f | tr ' ' '_'`
+ _cp "$srcdir/install/$f" "$pkgdir/$space_removal"
done
# Currently upstream systemd file does not automatically create run directory