summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-09-01 07:14:33 -0400
committerAndrew Sun2019-09-01 07:14:33 -0400
commitba79ff1c9a85cd3115f59b0a21400f5bec3fe827 (patch)
treea64ac06e5829f27f4633a914d46d639b2c08ae2f
parent401667afe9d687b01c629657cb40102131455767 (diff)
downloadaur-ba79ff1c9a85cd3115f59b0a21400f5bec3fe827.tar.gz
baresip: update to 0.6.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--baresip-flags.patch16
3 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bafe9d89633..3b2fcaabce21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = baresip
pkgdesc = portable and modular SIP User-Agent with audio and video support
- pkgver = 0.6.3
+ pkgver = 0.6.4
pkgrel = 1
url = http://www.creytiv.com/baresip.html
arch = i686
@@ -45,10 +45,10 @@ pkgbase = baresip
optdepends = spandsp: (g722, g726,plc modules)
optdepends = speexdsp: (speex_aec, speex_pp modules)
optdepends = v4l-utils: (v4l2 module)
- source = http://creytiv.com/pub/baresip-0.6.3.tar.gz
+ source = http://creytiv.com/pub/baresip-0.6.4.tar.gz
source = baresip-flags.patch
- sha256sums = c8005466b4947e28bc48ceb3d99608c782109970c2653b9d0eb0900d4695300c
- sha256sums = 55af521d77e105bb519f60464b2e50b83da15eb8549c18dabefa15215b22fa92
+ sha256sums = 61710bd1bec406ae1faf167c5743bad8eef9ced5152a3943b94d7e1cf9597581
+ sha256sums = 87562245c11d6599fc7821803ab313181106399102e00fb9ed79db693cbef18f
pkgname = baresip
diff --git a/PKGBUILD b/PKGBUILD
index 479c9bf8391c..ba6934f661f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dmitrij D. Czarkoff <czarkoff@gmail.com>
pkgname=baresip
-pkgver=0.6.3
+pkgver=0.6.4
pkgrel=1
pkgdesc="portable and modular SIP User-Agent with audio and video support"
arch=('i686' 'x86_64' 'armv6h')
@@ -31,8 +31,8 @@ optdepends=('alsa-lib: (alsa module)'
makedepends=(${optdepends[@]/%:*/})
source=("http://creytiv.com/pub/$pkgname-$pkgver.tar.gz"
"baresip-flags.patch")
-sha256sums=('c8005466b4947e28bc48ceb3d99608c782109970c2653b9d0eb0900d4695300c'
- '55af521d77e105bb519f60464b2e50b83da15eb8549c18dabefa15215b22fa92')
+sha256sums=('61710bd1bec406ae1faf167c5743bad8eef9ced5152a3943b94d7e1cf9597581'
+ '87562245c11d6599fc7821803ab313181106399102e00fb9ed79db693cbef18f')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/baresip-flags.patch b/baresip-flags.patch
index d19f5a0da970..1961b5301d8a 100644
--- a/baresip-flags.patch
+++ b/baresip-flags.patch
@@ -1,6 +1,6 @@
-diff -Naur baresip-0.6.2.orig/Makefile baresip-0.6.2/Makefile
---- baresip-0.6.2.orig/Makefile 2019-05-06 19:50:16.033903247 -0400
-+++ baresip-0.6.2/Makefile 2019-05-06 19:51:38.941047245 -0400
+diff -Naur baresip-0.6.4.orig/Makefile baresip-0.6.4/Makefile
+--- baresip-0.6.4.orig/Makefile 2019-09-01 07:06:16.102425225 -0400
++++ baresip-0.6.4/Makefile 2019-09-01 07:09:02.859444292 -0400
@@ -170,7 +170,7 @@
$(SHARED): $(LIB_OBJS)
@@ -26,14 +26,14 @@ diff -Naur baresip-0.6.2.orig/Makefile baresip-0.6.2/Makefile
$(TEST_BIN): $(STATICLIB) $(TEST_OBJS)
@echo " LD $@"
-- $(HIDE)$(CXX) $(LFLAGS) $(TEST_OBJS) \
-+ $(HIDE)$(CXX) $(LDFLAGS) $(LFLAGS) $(TEST_OBJS) \
+- $(HIDE)$(LD) $(LFLAGS) $(TEST_OBJS) \
++ $(HIDE)$(LD) $(LDFLAGS) $(LFLAGS) $(TEST_OBJS) \
-L$(LIBRE_SO) -L. \
-l$(PROJECT) -lre $(LIBS) $(TEST_LIBS) -o $@
-diff -Naur baresip-0.6.2.orig/mk/mod.mk baresip-0.6.2/mk/mod.mk
---- baresip-0.6.2.orig/mk/mod.mk 2019-05-06 19:50:16.037236599 -0400
-+++ baresip-0.6.2/mk/mod.mk 2019-05-06 20:04:34.508833761 -0400
+diff -Naur baresip-0.6.4.orig/mk/mod.mk baresip-0.6.4/mk/mod.mk
+--- baresip-0.6.4.orig/mk/mod.mk 2019-09-01 07:06:16.105758563 -0400
++++ baresip-0.6.4/mk/mod.mk 2019-09-01 07:10:26.363036053 -0400
@@ -33,7 +33,7 @@
$(MOD)$(MOD_SUFFIX): $($(MOD)_OBJS)