summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Quelhas2020-02-08 01:09:04 +0000
committerRodrigo Quelhas2020-02-08 01:09:04 +0000
commitfcca0e431626c29f72af25375192afad37669df1 (patch)
tree0bd02c80d5f12ef86504da68abfc2c3f6a497416
downloadaur-fcca0e431626c29f72af25375192afad37669df1.tar.gz
Added package
-rw-r--r--.INSTALL16
-rw-r--r--.MTREEbin0 -> 398 bytes
-rw-r--r--.PKGINFO11
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
-rw-r--r--barracudavpn.install7
6 files changed, 102 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..1ecbd83d6174
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,16 @@
+post_install() {
+ [ ! -d /etc/barracudavpn ] && mkdir /etc/barracudavpn
+ [ -d /etc/phionvpn/ca -a ! -d /etc/barracudavpn/ca ] && mv /etc/phionvpn/ca /etc/barracudavpn/ca
+ [ -f /etc/phionvpn/phionvpn2.conf -a ! -f /etc/barracudavpn/barracudavpn.conf ] && mv /etc/phionvpn/phionvpn2.conf /etc/barracudavpn/barracudavpn.conf
+ if [ -d /etc/phionvpn ]; then
+ for n in $(find /etc/phionvpn -type f); do
+ fn=$(basename $n)
+ [ ! -f /etc/barracudavpn/${fn} ] && mv $n /etc/barracudavpn/${fn}
+ done
+ fi
+ rmdir /etc/phionvpn 2>/dev/null
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/.MTREE b/.MTREE
new file mode 100644
index 000000000000..61001101c595
--- /dev/null
+++ b/.MTREE
Binary files differ
diff --git a/.PKGINFO b/.PKGINFO
new file mode 100644
index 000000000000..94e118da20a8
--- /dev/null
+++ b/.PKGINFO
@@ -0,0 +1,11 @@
+pkgname = barracudavpn
+pkgver = 5.0.2.7-1
+pkgdesc = Barracuda VPN client for linux - debian edition version 5.0.2.7
+url =
+builddate = 1581022326
+packager =
+arch = x86_64
+size = 5020432
+license =
+replaces = phionvpn
+conflict = phionvpn
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3be7234bc48a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = barracudavpn
+ pkgdesc = Barracuda VPN Client for Linux
+ pkgver = 5.0.2.7
+ pkgrel = 1
+ url = https://campus.barracuda.com/product/networkaccessclient
+ install = barracudavpn.install
+ arch = i386
+ arch = x86_64
+ license = custom:BarracudaVPN
+ depends = sh
+ depends = xterm
+ options = !strip
+ source = https://raw.githubusercontent.com/RomarQ/barracudavpn-archlinux/master/tarball/barracudavpn-5.0.2.7.tar.gz
+ sha256sums = fb034907eed5a344ca324479df1e03652903c6b375bf506a6059fcac05a63113
+
+pkgname = barracudavpn
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9837715c74a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Mike Achtelik <mike_achtelik at hotmail dot com>
+# Contributor: David Birks <david@tellus.space>
+# Contributor: Michele Cereda <cereda.michele@gmail.com>
+# Contributor: JokerYu <dayushinn@gmail.com>
+# Contributor: Olivier Bilodeau <obilodeau@gosecure.ca>
+
+pkgname="barracudavpn"
+pkgver="5.0.2.7"
+pkgrel="1"
+pkgdesc="Barracuda VPN Client for Linux"
+arch=("i386" "x86_64")
+install="${pkgname}.install"
+
+url="https://campus.barracuda.com/product/networkaccessclient"
+license=("custom:FortiClientSSLVPN")
+
+depends=(
+ "sh"
+ "xterm"
+)
+
+source=(
+ "https://raw.githubusercontent.com/RomarQ/barracudavpn-archlinux/master/tarball/${pkgname}-${pkgver}.tar.gz"
+)
+sha256sums=('fb034907eed5a344ca324479df1e03652903c6b375bf506a6059fcac05a63113')
+
+if [ "$CARCH" = "i386" ];
+then
+
+ bin_location="usr/local/bin"
+ bin_file="barracudavpn_32"
+
+elif [ "$CARCH" = "x86_64" ];
+then
+
+ bin_location="usr/bin"
+ bin_file="barracudavpn_64"
+
+fi
+options=( !strip )
+
+package() {
+ msg "Creating folders..."
+ mkdir -p ${pkgdir}/opt/${pkgname}/icons
+ mkdir -p ${pkgdir}/usr/share/applications
+ mkdir -p ${pkgdir}/${bin_location}
+
+ msg "Installing files..."
+ install -Dm 4755 ${srcdir}/${pkgname}/${bin_file} ${pkgdir}/${bin_location}/${pkgname}
+ install -Dm 4755 ${srcdir}/${pkgname}/${pkgname}.png ${pkgdir}/opt/${pkgname}/icons/
+ install -Dm 4755 ${srcdir}/${pkgname}/${bin_file}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}
diff --git a/barracudavpn.install b/barracudavpn.install
new file mode 100644
index 000000000000..a60d2563d18c
--- /dev/null
+++ b/barracudavpn.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "post_install"
+}
+
+post_upgrade() {
+ echo "post_upgrade"
+}