summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Libert2022-09-02 09:40:53 +0200
committerBart Libert2022-09-02 09:40:53 +0200
commit03cb01a28d9bb17ebc6095f1d73198aee4842e1f (patch)
tree97e37f6773e9ce3990b013cdec027b3dbc63cf1a
downloadaur-03cb01a28d9bb17ebc6095f1d73198aee4842e1f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD29
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e6a5a6d211d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = barracudavpn-bin
+ pkgdesc = Barracuda VPN Client for Linux - needs original download from Barracuda
+ pkgver = 5.2.2
+ pkgrel = 1
+ url = https://campus.barracuda.com/product/networkaccessclient
+ arch = i386
+ arch = x86_64
+ license = custom:FortiClientSSLVPN
+ provides = barracudavpn
+ conflicts = barracudavpn
+ options = debug
+ options = !strip
+ source = VPNClient_5.2.2_Linux.tar.gz::local://VPNClient_5.2.2_Linux.tar.gz
+ sha256sums = 91459886ec634eca30321dc975de3208591084b2103801365442ef9c4e38e4ae
+
+pkgname = barracudavpn-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd3452b6aded
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Bart Libert <aur@bart.libert.email>
+pkgname=barracudavpn-bin
+pkgver=5.2.2
+pkgrel=1
+pkgdesc="Barracuda VPN Client for Linux - needs original download from Barracuda"
+arch=("i386" "x86_64")
+conflicts=('barracudavpn')
+provides=('barracudavpn')
+
+url="https://campus.barracuda.com/product/networkaccessclient"
+license=("custom:FortiClientSSLVPN")
+
+_srctarball="VPNClient_${pkgver}_Linux.tar.gz"
+
+source=("${_srctarball}::local://${_srctarball}")
+sha256sums=('91459886ec634eca30321dc975de3208591084b2103801365442ef9c4e38e4ae')
+
+options=(debug !strip)
+
+prepare() {
+ cd "${srcdir}"
+ ar x barracudavpn_${pkgver}_amd64.deb data.tar.xz
+ tar -xf data.tar.xz
+}
+
+package() {
+ echo "${pkgdir}"
+ install -Dm 4755 ${srcdir}/usr/local/bin/barracudavpn ${pkgdir}/usr/bin/barracudavpn
+}