summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilman Blumenbach2018-04-29 15:05:21 +0200
committerTilman Blumenbach2018-04-29 15:12:29 +0200
commit6e20571587f4e541f5da80a1ced63f363e6144c1 (patch)
tree93d87ebacd6dfaa6f31634836693545b9afd022d
downloadaur-6e20571587f4e541f5da80a1ced63f363e6144c1.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD48
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84b788320e23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = barrier
+ pkgdesc = Open-source KVM software based on Synergy
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/debauchee/barrier
+ arch = x86_64
+ license = custom:GPL2WithOpenSSLException
+ makedepends = cmake
+ depends = curl
+ depends = libx11
+ depends = libxrandr
+ depends = libxext
+ depends = libxinerama
+ depends = xorgproto
+ depends = libxtst
+ depends = libxi
+ depends = avahi
+ depends = libsm
+ depends = libice
+ depends = openssl
+ depends = qt5-base
+ depends = hicolor-icon-theme
+ source = https://github.com/debauchee/barrier/archive/v2.0.0.tar.gz
+ sha256sums = 713b0850895eac184ecf30b002da0be9bf90dda3ba0b68a0f6ba6c6ecc06806f
+
+pkgname = barrier
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..775dc7ecfd37
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg/
+/src/
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f66ab6118e63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Tilman BLUMENBACH <tilman+aur AT ax86 DOT net>
+
+pkgname=barrier
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Open-source KVM software based on Synergy"
+url="https://github.com/debauchee/barrier"
+license=("custom:GPL2WithOpenSSLException")
+source=("https://github.com/debauchee/barrier/archive/v${pkgver?}.tar.gz")
+arch=(x86_64)
+depends=(curl libx11 libxrandr libxext libxinerama xorgproto libxtst libxi avahi libsm libice openssl qt5-base
+ hicolor-icon-theme)
+makedepends=(cmake)
+
+build() {
+ cd "barrier-${pkgver?}"
+
+ mkdir -p build
+ cd build
+
+ cmake -G "Unix Makefiles" \
+ -D CMAKE_BUILD_TYPE:STRING=Release \
+ -D CMAKE_INSTALL_PREFIX:STRING=/usr \
+ -D BARRIER_REVISION:STRING=00000000 \
+ -D BARRIER_VERSION_STAGE:STRING=RELEASE \
+ ..
+ make
+}
+
+package() {
+ # Install binaries:
+ cd "barrier-${pkgver?}/build"
+ DESTDIR="${pkgdir?}" make install
+
+ # Install the license:
+ cd ..
+ install -m 644 -D LICENSE "${pkgdir?}/usr/share/licenses/${pkgname?}/LICENSE"
+
+ # Install the manpages:
+ mkdir -p "${pkgdir?}/usr/share/man/man1"
+ install -m 644 doc/*.1 "${pkgdir?}/usr/share/man/man1"
+
+ # Install the examples:
+ mkdir -p "${pkgdir?}/usr/share/doc/${pkgname?}"
+ install -m 644 doc/barrier.conf* "${pkgdir?}/usr/share/doc/${pkgname?}"
+}
+
+sha256sums=('713b0850895eac184ecf30b002da0be9bf90dda3ba0b68a0f6ba6c6ecc06806f')