summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordotiful2020-03-22 23:02:37 +0200
committerdotiful2020-03-22 23:02:37 +0200
commit8fbc508f7783565cc2dd039ad310ac8778c6037b (patch)
tree2f646b3a5e7908ac88da4769e58cca40b8085c6d
downloadaur-8fbc508f7783565cc2dd039ad310ac8778c6037b.tar.gz
2.3.2
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD43
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..303f77113865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = barrier-bin
+ pkgdesc = Open-source KVM software based on Synergy
+ pkgver = 2.3.2
+ pkgrel = 1
+ url = https://github.com/debauchee/barrier
+ arch = x86_64
+ license = custom:GPL2WithOpenSSLException
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = hicolor-icon-theme
+ depends = curl
+ depends = avahi
+ depends = libx11
+ depends = libxrandr
+ depends = libxext
+ depends = libxinerama
+ depends = xorgproto
+ depends = libxtst
+ depends = libxi
+ depends = libsm
+ depends = libice
+ depends = openssl
+ provides = barrier=2.3.2
+ conflicts = barrier
+ conflicts = barrier-headless
+ noextract = barrier-2.3.2-x86_64.tar.xz
+ options = !emptydirs
+ options = !makeflags
+ options = !strip
+ source = https://github.com/dotiful/AUR/raw/master/barrier-bin/barrier-2.3.2-x86_64.tar.xz
+ sha256sums = e65088db4f282f01301e6ca4f1c829216cba50b07d01d1d42ed4c8a626e80da3
+
+pkgname = barrier-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..04eebdd9da58
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+git.sh \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..440787837e72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Art Dev <artdevjs at gmail dot com>
+pkgname=barrier-bin
+pkgver=2.3.2
+pkgrel=1
+pkgdesc="Open-source KVM software based on Synergy"
+arch=(x86_64)
+url="https://github.com/debauchee/barrier"
+license=("custom:GPL2WithOpenSSLException")
+depends=(
+ # Barrier core dependencies:
+ curl
+ avahi
+ libx11
+ libxrandr
+ libxext
+ libxinerama
+ xorgproto
+ libxtst
+ libxi
+ libsm
+ libice
+ openssl
+)
+makedepends=(
+ cmake
+
+ # Barrier GUI dependencies:
+ qt5-base
+ hicolor-icon-theme
+)
+provides=("barrier=$pkgver")
+conflicts=(barrier barrier-headless)
+options=(!emptydirs !makeflags !strip)
+source=(
+ https://github.com/dotiful/AUR/raw/master/barrier-bin/barrier-${pkgver}-${CARCH}.tar.xz
+)
+noextract=(barrier-${pkgver}-${CARCH}.tar.xz)
+
+package() {
+ tar -xf $srcdir/barrier-${pkgver}-${CARCH}.tar.xz -C $pkgdir --exclude=".*"
+}
+
+sha256sums=('e65088db4f282f01301e6ca4f1c829216cba50b07d01d1d42ed4c8a626e80da3') \ No newline at end of file