summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonny Lorenz2015-09-18 12:45:56 +0200
committerRonny Lorenz2015-09-18 12:45:56 +0200
commitecfd78468281d7b50cd91cf99ee433b8fe57d4c8 (patch)
treef439f990d87c5540b7e02486db2cc29f7dd29159
downloadaur-ecfd78468281d7b50cd91cf99ee433b8fe57d4c8.tar.gz
Initial commit of version 1.5.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a64c3cec316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = barriers
+ pkgdesc = Compute local minima and energy barriers of a landscape
+ pkgver = 1.5.2
+ pkgrel = 1
+ url = http://www.tbi.univie.ac.at/RNA/Barriers
+ arch = armv7h
+ arch = x86_64
+ arch = i686
+ license = Custom
+ optdepends = viennarna: Generate sets of suboptimal RNA secondary structures with RNAsubopt
+ optdepends = treekin: Compute folding dynamics using barriers generated transition rates
+ source = http://www.tbi.univie.ac.at/RNA/Barriers/Barriers-1.5.2.tar.gz
+ md5sums = a2f214f41a2f7af1d9380803d5fea441
+
+pkgname = barriers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..675a554db4da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ronny Lorenz <ronny at tbi dot univie dot ac dot at>
+
+pkgname=barriers
+pkgver=1.5.2
+pkgrel=1
+pkgdesc="Compute local minima and energy barriers of a landscape"
+arch=('armv7h' 'x86_64' 'i686')
+license=('Custom')
+url="http://www.tbi.univie.ac.at/RNA/Barriers"
+depends=()
+optdepends=('viennarna: Generate sets of suboptimal RNA secondary structures with RNAsubopt'
+ 'treekin: Compute folding dynamics using barriers generated transition rates')
+makedepends=()
+provides=()
+source=(http://www.tbi.univie.ac.at/RNA/Barriers/Barriers-${pkgver}.tar.gz)
+md5sums=('a2f214f41a2f7af1d9380803d5fea441')
+
+build() {
+ cd "${srcdir}/Barriers-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/Barriers-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+