summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Holme2021-06-09 16:43:51 +0200
committerChristian Holme2021-06-09 16:43:51 +0200
commit562329216de61f280e99c1fc58126c34bc2e8200 (patch)
treee5630334bc7cba4d022f31bb28ad7667e88bcfdf
downloadaur-562329216de61f280e99c1fc58126c34bc2e8200.tar.gz
v0.7.00
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96fd9a2684cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bart
+ pkgdesc = Berkeley Advanced Reconstruction Toolbox (BART) for Computational Magnetic Resonance Imaging
+ pkgver = 0.7.00
+ pkgrel = 1
+ url = https://mrirecon.github.io/bart/
+ arch = x86_64
+ license = BSD
+ depends = gcc10
+ depends = gcc10-libs
+ depends = openblas-lapack
+ depends = fftw
+ depends = libpng
+ optdepends = octave
+ optdepends = python3
+ conflicts = bart-git
+ source = https://github.com/mrirecon/bart/archive/refs/tags/v0.7.00.tar.gz
+ sha512sums = 53eec57f1e81d7d8cecfcca4828b28fedb8ae8fd1e38de652b9c8263309c74726d36e18ec683d511e11047d711903541ce1784051f79b9e00cc07ee29381c642
+
+pkgname = bart
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..839db3b684c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Christian Holme (Nordwin) <hcmh [at] kolabnow [dot] com>
+# Contributor: Thomas Roos (Roosted7) <mail [at] thomasroos [dot] nl>
+
+pkgname=bart
+pkgver=0.7.00
+pkgrel=1
+pkgdesc="Berkeley Advanced Reconstruction Toolbox (BART) for Computational Magnetic Resonance Imaging"
+arch=('x86_64')
+url="https://mrirecon.github.io/bart/"
+license=('BSD')
+depends=('gcc10' 'gcc10-libs' 'openblas-lapack' 'fftw' 'libpng')
+optdepends=('octave' 'python3')
+source=("https://github.com/mrirecon/bart/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('53eec57f1e81d7d8cecfcca4828b28fedb8ae8fd1e38de652b9c8263309c74726d36e18ec683d511e11047d711903541ce1784051f79b9e00cc07ee29381c642')
+conflicts=('bart-git')
+
+build() {
+ cd "$pkgname"-"$pkgver"
+
+ make CC=gcc-10
+}
+
+package() {
+ cd "$pkgname"-"$pkgver"
+ make CC=gcc-10 PREFIX="$pkgdir"/usr install
+
+ # Also install the libs, the viewer needs this and its not done by the Makefile atm
+ install -d "$pkgdir"/usr/lib/bart
+ install -m644 lib/* "$pkgdir"/usr/lib/bart
+
+ # Also install the headers, the viewer needs this and its not done by the Makefile atm
+ install -d "$pkgdir"/usr/include/bart
+ cd src
+ for file in $(find ./ -type f -name "*.h"); do
+ install -D ${file} "$pkgdir"/usr/include/bart/${file}
+ done
+ cd ..
+
+ install -d "$pkgdir"/usr/share/bart/matlab
+ install matlab/* "$pkgdir"/usr/share/bart/matlab
+
+ install -d "$pkgdir"/usr/share/bart/python
+ install python/* "$pkgdir"/usr/share/bart/python
+
+ install -d "$pkgdir"/usr/share/bart/scripts
+ install scripts/* "$pkgdir"/usr/share/bart
+
+ # Install license, since each BSD license is technically a custom license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}