summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUmamiAppearance2022-12-13 11:05:52 +0100
committerUmamiAppearance2022-12-13 11:05:52 +0100
commite73e4eb36222200b78c00120d152e0002f7cf32a (patch)
treeb6a85e74310d3221856a0ed6f063c2b7b6617189
downloadaur-e73e4eb36222200b78c00120d152e0002f7cf32a.tar.gz
Initial Commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0b1aee7e43d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = base-ex-cli
+ pkgdesc = CLI for BaseEx (base conversion)
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/UmamiAppearance/BaseExCLI
+ arch = x86_64
+ license = GPL
+ makedepends = npm
+ noextract = base-ex-cli-0.2.3.tgz
+ source = https://registry.npmjs.org/base-ex-cli/-/base-ex-cli-0.2.3.tgz
+ sha256sums = 60d3cc9986aa46e0348277c7140c04548b718c459305e1c29b2c57e83c4a48db
+
+pkgname = base-ex-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58deee5e7afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: UmamiAppearance <mail@umamiappearance.eu>
+
+pkgname=base-ex-cli
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="CLI for BaseEx (base conversion)"
+arch=(x86_64)
+url=https://github.com/UmamiAppearance/BaseExCLI
+license=("GPL")
+makedepends=('npm')
+noextract=("${pkgname}-${pkgver}.tgz")
+source=("https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz")
+sha256sums=("60d3cc9986aa46e0348277c7140c04548b718c459305e1c29b2c57e83c4a48db")
+
+package() {
+ npm install -g --prefix "${pkgdir}/usr" --cache "${srcdir}/npm-cache" "${srcdir}/${pkgname}-${pkgver}.tgz"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+}
+