summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmanuel Duss2017-03-12 16:25:54 +0100
committerEmanuel Duss2017-03-12 16:27:00 +0100
commit278dda32279628541938977268401e18a1b28e9a (patch)
treec9d08200144301831a30e6028b1743fa79a5f56a
downloadaur-278dda32279628541938977268401e18a1b28e9a.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD19
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..257d8eb4d9ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = base16
+ pkgdesc = base16 (hex) encode/decode data and print to standard output
+ pkgver = 20170315
+ pkgrel = 1
+ url = https://github.com/mindfuckup/Scripts/blob/master/base16
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = perl
+ source = https://raw.githubusercontent.com/mindfuckup/Scripts/master/base16
+ source = https://raw.githubusercontent.com/mindfuckup/Scripts/master/LICENSE
+ sha256sums = f6b8592226e51dc5b6addb489db6acd117b80a5a8fe18c292993078ad1967109
+ sha256sums = 1aa1b3610e6a8f9776bbacfddd3c6818244dc3268c8661f41b6aed7293fadb2d
+
+pkgname = base16
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f3857d04c081
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+base16
+base16-*-x86_64.pkg.tar.xz
+LICENSE
+pkg/
+PKGBUILD
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28965a4f6ece
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Emanuel Duss <emanuel.duss@gmail.com>
+pkgname=base16
+pkgver=20170315
+pkgrel=1
+pkgdesc="base16 (hex) encode/decode data and print to standard output"
+url="https://github.com/mindfuckup/Scripts/blob/master/base16"
+license=('custom')
+source=('https://raw.githubusercontent.com/mindfuckup/Scripts/master/base16'
+ 'https://raw.githubusercontent.com/mindfuckup/Scripts/master/LICENSE')
+sha256sums=('f6b8592226e51dc5b6addb489db6acd117b80a5a8fe18c292993078ad1967109'
+ '1aa1b3610e6a8f9776bbacfddd3c6818244dc3268c8661f41b6aed7293fadb2d')
+
+arch=('i686' 'x86_64')
+depends=(perl)
+
+package(){
+ install -D -m755 "${srcdir}/base16" "${pkgdir}/usr/bin/base16"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}