summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Christian Pohle2020-05-25 01:08:41 +0200
committerMax Christian Pohle2020-05-25 01:12:40 +0200
commit8dedaf7a659d75ebadc7b46c57c24c24065f77d9 (patch)
tree0ad4ed197b9e1b7610abf43702afaa398b6b9c2b
downloadaur-8dedaf7a659d75ebadc7b46c57c24c24065f77d9.tar.gz
Initial AUR package release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--base16-vtrgb.install20
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67be7eca1514
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = base16-vtrgb
+ pkgdesc = base16 color schemes available for the virtual terminal (vt, tty)
+ pkgver = 2020_05_24
+ pkgrel = 1
+ url = https://github.com/coderonline/base16-vtrgb
+ install = base16-vtrgb.install
+ arch = any
+ license = MIT
+ depends = systemd
+ depends = kbd
+ depends = mkinitcpio
+ backup = etc/vtrgb
+ source = base16-vtrgb-2020_05_24.tar.gz::https://github.com/coderonline/base16-vtrgb/archive/2020-05-24.tar.gz
+ sha256sums = b7b1c9906b219ee7b4c7b6f34585dc50b8d1ffa3378826c287f20cc7af99b594
+
+pkgname = base16-vtrgb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd34489f6723
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jguer <joaogg3@gmail.com>
+pkgname=base16-vtrgb
+pkgver=2020_05_24
+pkgrel=1
+pkgdesc="base16 color schemes available for the virtual terminal (vt, tty)"
+arch=('any')
+url="https://github.com/coderonline/base16-vtrgb"
+license=('MIT')
+depends=(
+ 'systemd'
+ 'kbd'
+ 'mkinitcpio'
+)
+backup=('etc/vtrgb')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/coderonline/base16-vtrgb/archive/${pkgver//_/-}.tar.gz")
+sha256sums=('b7b1c9906b219ee7b4c7b6f34585dc50b8d1ffa3378826c287f20cc7af99b594')
+install='base16-vtrgb.install'
+
+package() {
+ VERSION=${pkgver//_/-}
+ cd ..
+ mkdir -p pkg/${pkgname}/usr/share/kbd/
+ mkdir -p pkg/${pkgname}/usr/lib/initcpio/hooks/
+ mkdir -p pkg/${pkgname}/usr/lib/initcpio/install/
+ mkdir -p pkg/${pkgname}/etc/
+ cat /sys/module/vt/parameters/default_{red,grn,blu} > pkg/${pkgname}/etc/vtrgb
+ cp -a src/base16-vtrgb-${VERSION}/initcpio/hooks/setvtrgb pkg/${pkgname}/usr/lib/initcpio/hooks/
+ cp -a src/base16-vtrgb-${VERSION}/initcpio/install/setvtrgb pkg/${pkgname}/usr/lib/initcpio/install/
+ cp -ar src/base16-vtrgb-${VERSION}/consolecolors pkg/${pkgname}/usr/share/kbd/
+}
+
+# vim: ft=bash
diff --git a/base16-vtrgb.install b/base16-vtrgb.install
new file mode 100644
index 000000000000..488173cd9a56
--- /dev/null
+++ b/base16-vtrgb.install
@@ -0,0 +1,20 @@
+post_install() {
+ # do something here
+ cat <<HELPEOF
+
+1) Do not forget to append the 'setvtrgb' hook to your '/etc/mkinitcpio.conf'
+
+2) configure your desired colorscheme by creating a symlink to '/etc/vtrgb':
+ 'ln -sf /usr/share/kbd/consolecolors/base16-tomorrow.vga /etc/vtrgb'
+
+3) Recreate your initramfs, in most cases with 'mkinitcpio -p linux'
+
+HELPEOF
+}
+
+post_remove() {
+ cat <<HELPEOF
+ Do not forget to remove the setvtrgb hook from '/etc/mkinitcpio.conf' and
+ recreate your initcpio image most commonly with 'mkinitcpio -p linux'
+HELPEOF
+}