summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Lee2015-10-31 12:17:23 -0400
committerMark Lee2015-10-31 12:17:23 -0400
commitd7f8db53be9dc4fb01329d0aaaf3b8b6c1e1293c (patch)
tree69f1f11045b9a5ffa346c3b0a7c3a465a8ff9867
downloadaur-baseos-squashfs.tar.gz
Added PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6098515e858e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Oct 31 16:16:53 UTC 2015
+pkgbase = baseos-squashfs
+ pkgdesc = Initcpio hooks for baseOS boot
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/bluerider/baseOS.git
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = util-linux
+ source = git+https://github.com/bluerider/baseOS.git
+ sha256sums = SKIP
+
+pkgname = baseos-squashfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef49746baa3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+#Maintainer : mark@markelee.com
+#Contributor : mark@markelee.com
+
+pkgname='baseos-squashfs'
+url='https://github.com/bluerider/baseOS.git'
+pkgdesc='Initcpio hooks for baseOS boot'
+pkgver=1
+pkgrel=1
+arch=('any')
+depends=('util-linux')
+makedepends=('git')
+license=('GPL3')
+source=("git+$url")
+sha256sums=('SKIP')
+
+package() {
+ install -m755 -d "${pkgdir}/usr/lib/initcpio/hooks"
+ install -m755 -d "${pkgdir}/usr/lib/initcpio/install"
+ install -m644 {"${srcdir}/baseOS/initcpio-hooks","${pkgdir}/usr/lib/initcpio"}/hooks/squashfs
+ install -m644 {"${srcdir}/baseOS/initcpio-hooks","${pkgdir}/usr/lib/initcpio"}/install/squashfs
+}