summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrokenpip32021-12-12 19:37:27 +0100
committerbrokenpip32021-12-12 19:37:27 +0100
commit4ad21fecbc91cd303a3e9366e29c1ae1ec9d7b8c (patch)
tree033d9f92a8e86b0a76ecb49c181253e64912167c
downloadaur-4ad21fecbc91cd303a3e9366e29c1ae1ec9d7b8c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
-rw-r--r--bash-bats-file.install4
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ed0179d6f5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bash-bats-file
+ pkgdesc = A library to ease e2e tests of applications in K8s environments with bats
+ pkgver = 0.3.0
+ pkgrel = 2
+ url = https://github.com/bats-core/bats-file
+ install = bash-bats-file.install
+ arch = any
+ license = MIT
+ depends = bash-bats
+ source = https://github.com/bats-core/bats-file/archive/v0.3.0/bash-bats-file-0.3.0.tar.gz
+ sha512sums = 948249ba72aa027153bdab55438e0b705c1efd06a934003ac60a51d839b0c91c0cb59b55260adcacfcaca9af5eed66c0c4197140aeb4db9dfbcc7ebed5cd4362
+
+pkgname = bash-bats-file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9007abb6125d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Brokenpip3 <brokenpip3[at]gmail[dot]com>
+
+pkgname=bash-bats-file
+pkgver=0.3.0
+pkgrel=2
+pkgdesc="A library to ease e2e tests of applications in K8s environments with bats"
+arch=("any")
+url="https://github.com/bats-core/bats-file"
+license=("MIT")
+depends=('bash-bats')
+install=bash-bats-file.install
+source=("https://github.com/bats-core/bats-file/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('948249ba72aa027153bdab55438e0b705c1efd06a934003ac60a51d839b0c91c0cb59b55260adcacfcaca9af5eed66c0c4197140aeb4db9dfbcc7ebed5cd4362')
+
+check() {
+ cd "${srcdir}/bats-file-${pkgver}"
+ echo "tests contains sudo invocation, will avoid to run them"
+ #TEST_DEPS_DIR="/usr/lib/" bats test
+}
+
+package() {
+ cd "${srcdir}/bats-file-${pkgver}"
+
+ for fn in *.bash; do
+ install -Dm755 ${fn} "${pkgdir}/usr/lib/bats-file/$(basename $fn)"
+ done
+
+ for fn in src/*.bash; do
+ install -Dm755 ${fn} "${pkgdir}/usr/lib/bats-file/src/$(basename $fn)"
+ done
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/bash-bats-file.install b/bash-bats-file.install
new file mode 100644
index 000000000000..b83422f7bf7f
--- /dev/null
+++ b/bash-bats-file.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo -e "\nTo use bat-file library add this line\nto your bats test or common_setup function"
+ echo -e '\nload "/lib/bats-file/load.bash" \n'
+}