summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens John2015-09-16 11:52:41 +0200
committerJens John2015-09-16 11:52:41 +0200
commit2074a2347d8132cfeb4fb0bf7cc0de0f1f80fdf4 (patch)
tree418892a18684731ec438827abb37a4caebdf0f8e
parent1475ba7270823d182a7aec41d592cc62b34f6239 (diff)
downloadaur-bash-ctypes-git.tar.gz
Upstream build system changed to autotools
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--archlinux-pkgconfig.patch19
-rw-r--r--bash-ctypes-git.install9
4 files changed, 22 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15ce1333f3f0..eb8c4567e724 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = bash-ctypes-git
pkgdesc = Foreign Function Interface for Bash
- pkgver = r12.7cded42
+ pkgver = r56.b0800b2
pkgrel = 1
url = https://github.com/taviso/ctypes.sh
+ install = bash-ctypes-git.install
arch = x86_64
arch = i686
license = MIT
makedepends = git
makedepends = libffi
- makedepends = pkg-config
+ makedepends = autoconf
+ makedepends = automake
depends = bash
depends = libffi
provides = bash-ctypes
conflicts = bash-ctypes
source = bash-ctypes::git+https://github.com/taviso/ctypes.sh#branch=master
- source = archlinux-pkgconfig.patch
source = ctypes_bash_profile.sh
md5sums = SKIP
- md5sums = d62e880683bab33be4d845602d77f237
md5sums = 8f94ef9e242b89d5ea860527e2595f2c
pkgname = bash-ctypes-git
diff --git a/PKGBUILD b/PKGBUILD
index 73cedbd07f56..9a417ed1cb0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: 2ion <dev at 2ion dot de>
+# Maintainer: 2ion
pkgname=bash-ctypes-git
-pkgver=r12.7cded42
+pkgver=r56.b0800b2
pkgrel=1
pkgdesc="Foreign Function Interface for Bash"
arch=('x86_64' 'i686')
url="https://github.com/taviso/ctypes.sh"
license=('MIT')
depends=('bash' 'libffi')
-makedepends=('git' 'libffi' 'pkg-config')
+makedepends=('git' 'libffi' 'autoconf' 'automake' 'libtool')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=(\
- 'bash-ctypes::git+https://github.com/taviso/ctypes.sh#branch=master'\
- 'archlinux-pkgconfig.patch'\
+ 'bash-ctypes::git+https://github.com/taviso/ctypes.sh#branch=master' \
'ctypes_bash_profile.sh')
md5sums=(\
- 'SKIP'\
- 'd62e880683bab33be4d845602d77f237'\
+ 'SKIP' \
'8f94ef9e242b89d5ea860527e2595f2c')
+install=${pkgname}.install
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -26,7 +25,8 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
- patch -p1 -i "$srcdir/archlinux-pkgconfig.patch"
+ autoreconf -vifs
+ ./configure --prefix=/usr
}
build() {
@@ -36,7 +36,6 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
- install -Dm755 ctypes.sh "${pkgdir}/usr/bin/ctypes.sh"
- install -Dm755 ctypes.so "${pkgdir}/usr/lib/ctypes.so"
+ make install DESTDIR="$pkgdir"
install -Dm755 "${srcdir}/ctypes_bash_profile.sh" "${pkgdir}/etc/profile.d/ctypes.sh"
}
diff --git a/archlinux-pkgconfig.patch b/archlinux-pkgconfig.patch
deleted file mode 100644
index f31e44699a99..000000000000
--- a/archlinux-pkgconfig.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 5ba179a87a206f284b0eb2e91665617a849ef0f2
-Author: Jens John <dev@2ion.de>
-Date: Tue Jul 28 15:27:08 2015 +0200
-
- Patched Makefile
-
-diff --git a/Makefile b/Makefile
-index 8a87263..bc41df8 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,6 +1,6 @@
--CFLAGS = -std=gnu99 -fPIC -O0 -ggdb3 -Wall -Wextra -fvisibility=hidden
-+CFLAGS = -std=gnu99 -fPIC -O0 -ggdb3 -Wall -Wextra -fvisibility=hidden $(shell pkg-config --cflags libffi)
- CPPFLAGS= -Iinclude
--LDLIBS = -lffi -ldl
-+LDLIBS = $(shell pkg-config --libs libffi) -ldl
- PREFIX = /usr/local
-
- .PHONY: clean install
diff --git a/bash-ctypes-git.install b/bash-ctypes-git.install
new file mode 100644
index 000000000000..567523dc7bf4
--- /dev/null
+++ b/bash-ctypes-git.install
@@ -0,0 +1,9 @@
+post_install()
+{
+ libtool --finish /usr/lib 1>/dev/null 2>/dev/null
+}
+
+post_upgrade()
+{
+ post_install
+}