summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemeplex2015-08-05 11:34:23 -0300
committermemeplex2015-08-05 11:34:23 -0300
commitab687e9e47b187fbd8dcf67b4f360750b59f3c13 (patch)
treefce37e1b0f68690f2192c266896db604666fac54
downloadaur-ab687e9e47b187fbd8dcf67b4f360750b59f3c13.tar.gz
Initial commit.
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD61
-rw-r--r--bash.install16
-rw-r--r--dot.bash_logout3
-rw-r--r--dot.bash_profile5
-rw-r--r--dot.bashrc9
-rw-r--r--system.bash_logout3
-rw-r--r--system.bashrc23
8 files changed, 153 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01792cc776ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = bash-devel-git
+ pkgdesc = The GNU Bourne Again shell (Development version)
+ pkgver = 4.20150805
+ pkgrel = 1
+ url = http://savannah.gnu.org/git/?group=bash
+ install = bash.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = readline>=7.0
+ depends = glibc
+ optdepends = bash-completion: for tab completion
+ provides = sh
+ provides = bash=4.20150805
+ conflicts = bash
+ backup = etc/bash.bashrc
+ backup = etc/bash.bash_logout
+ backup = etc/skel/.bashrc
+ backup = etc/skel/.bash_profile
+ backup = etc/skel/.bash_logout
+ source = dot.bashrc
+ source = dot.bash_profile
+ source = dot.bash_logout
+ source = system.bashrc
+ source = system.bash_logout
+ md5sums = 027d6bd8f5f6a06b75bb7698cb478089
+ md5sums = 2902e0fee7a9168f3a4fd2ccd60ff047
+ md5sums = 42f4400ed2314bd7519c020d0187edc5
+ md5sums = 561949793177116b7be29a07c385ba8b
+ md5sums = 472f536d7c9e8250dc4568ec4cfaf294
+
+pkgname = bash-devel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..719ebf70a0d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# $Id: PKGBUILD 239705 2015-05-24 12:41:19Z bpiotrowski $
+# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=bash-devel-git
+pkgdesc='The GNU Bourne Again shell (Development version)'
+pkgver="4.`date +%G%m%d`"
+pkgrel=1
+url='http://savannah.gnu.org/git/?group=bash'
+arch=('i686' 'x86_64')
+license=('GPL')
+backup=(etc/bash.bash{rc,_logout} etc/skel/.bash{rc,_profile,_logout})
+depends=('readline>=7.0' 'glibc')
+optdepends=('bash-completion: for tab completion')
+provides=('sh' "bash=$pkgver")
+conflicts=('bash')
+install=bash.install
+source=(dot.bashrc
+ dot.bash_profile
+ dot.bash_logout
+ system.bashrc
+ system.bash_logout)
+md5sums=('027d6bd8f5f6a06b75bb7698cb478089'
+ '2902e0fee7a9168f3a4fd2ccd60ff047'
+ '42f4400ed2314bd7519c020d0187edc5'
+ '561949793177116b7be29a07c385ba8b'
+ '472f536d7c9e8250dc4568ec4cfaf294')
+
+build() {
+ cd "$srcdir"
+ git clone --depth 1 --branch devel git://git.savannah.gnu.org/bash.git
+ cd bash
+ git checkout devel
+ _bashconfig=(-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/bin\"\'
+ -DSTANDARD_UTILS_PATH=\'\"/usr/bin\"\'
+ -DSYS_BASHRC=\'\"/etc/bash.bashrc\"\'
+ -DSYS_BASH_LOGOUT=\'\"/etc/bash.bash_logout\"\')
+ export CFLAGS="${CFLAGS} ${_bashconfig[@]}"
+ ./configure --prefix=/usr --with-curses --enable-readline \
+ --without-bash-malloc --with-installed-readline
+ make
+}
+
+package() {
+ pushd "$srcdir/bash"
+ make DESTDIR="$pkgdir" install
+ popd
+
+ ln -s bash "$pkgdir"/usr/bin/sh
+
+ # system-wide configuration files
+ install -m644 system.bashrc $pkgdir/etc/bash.bashrc
+ install -m644 system.bash_logout "$pkgdir"/etc/bash.bash_logout
+
+ # user configuration file skeletons
+ install -dm755 "$pkgdir"/etc/skel/
+ install -m644 dot.bashrc "$pkgdir"/etc/skel/.bashrc
+ install -m644 dot.bash_profile "$pkgdir"/etc/skel/.bash_profile
+ install -m644 dot.bash_logout "$pkgdir"/etc/skel/.bash_logout
+}
diff --git a/bash.install b/bash.install
new file mode 100644
index 000000000000..a10e6e909a66
--- /dev/null
+++ b/bash.install
@@ -0,0 +1,16 @@
+info_dir=usr/share/info
+info_files=(bash.info)
+
+post_upgrade() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
diff --git a/dot.bash_logout b/dot.bash_logout
new file mode 100644
index 000000000000..0e4e4f1845f2
--- /dev/null
+++ b/dot.bash_logout
@@ -0,0 +1,3 @@
+#
+# ~/.bash_logout
+#
diff --git a/dot.bash_profile b/dot.bash_profile
new file mode 100644
index 000000000000..5545f007ea9b
--- /dev/null
+++ b/dot.bash_profile
@@ -0,0 +1,5 @@
+#
+# ~/.bash_profile
+#
+
+[[ -f ~/.bashrc ]] && . ~/.bashrc
diff --git a/dot.bashrc b/dot.bashrc
new file mode 100644
index 000000000000..a355b0cd3267
--- /dev/null
+++ b/dot.bashrc
@@ -0,0 +1,9 @@
+#
+# ~/.bashrc
+#
+
+# If not running interactively, don't do anything
+[[ $- != *i* ]] && return
+
+alias ls='ls --color=auto'
+PS1='[\u@\h \W]\$ '
diff --git a/system.bash_logout b/system.bash_logout
new file mode 100644
index 000000000000..a76e48e4ae67
--- /dev/null
+++ b/system.bash_logout
@@ -0,0 +1,3 @@
+#
+# /etc/bash.bash_logout
+#
diff --git a/system.bashrc b/system.bashrc
new file mode 100644
index 000000000000..4d7a64344887
--- /dev/null
+++ b/system.bashrc
@@ -0,0 +1,23 @@
+#
+# /etc/bash.bashrc
+#
+
+# If not running interactively, don't do anything
+[[ $- != *i* ]] && return
+
+PS1='[\u@\h \W]\$ '
+PS2='> '
+PS3='> '
+PS4='+ '
+
+case ${TERM} in
+ xterm*|rxvt*|Eterm|aterm|kterm|gnome*)
+ PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
+
+ ;;
+ screen)
+ PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033_%s@%s:%s\033\\" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
+ ;;
+esac
+
+[ -r /usr/share/bash-completion/bash_completion ] && . /usr/share/bash-completion/bash_completion