summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-06 15:17:57 +0800
committerChocobo12023-04-06 15:17:57 +0800
commite9512688b61127c5d00faf10075ef91ec4d40c66 (patch)
tree3f506fc8503db3f5a203654d9f01bbe57a2bfd88
parente0e588e908e514e9db12d6b01fa15c2fc261da18 (diff)
downloadaur-e9512688b61127c5d00faf10075ef91ec4d40c66.tar.gz
upgpkg: bash-devel-git 5.2.r1161.gec9447ce-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 856b99f9e4eb..c98280cce108 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bash-devel-git
pkgdesc = The GNU Bourne Again shell (development version)
- pkgver = r1155.g75c5460c
+ pkgver = 5.2.r1161.gec9447ce
pkgrel = 1
url = https://www.gnu.org/software/bash/bash.html
arch = i686
@@ -11,7 +11,7 @@ pkgbase = bash-devel-git
depends = ncurses
depends = readline>=7.0
optdepends = bash-completion: for tab completion
- provides = bash
+ provides = bash=5.2.r1161.gec9447ce
provides = sh
conflicts = bash
backup = etc/bash.bashrc
@@ -33,4 +33,3 @@ pkgbase = bash-devel-git
sha256sums = SKIP
pkgname = bash-devel-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 42b352454906..c8bdf33e5d35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Aaron Griffin <aaron@archlinux.org>
pkgname=bash-devel-git
-pkgver=r1155.g75c5460c
+pkgver=5.2.r1161.gec9447ce
pkgrel=1
pkgdesc="The GNU Bourne Again shell (development version)"
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ license=('GPL')
depends=('glibc' 'ncurses' 'readline>=7.0')
makedepends=('git')
optdepends=('bash-completion: for tab completion')
-provides=('bash' 'sh')
+provides=("bash=$pkgver" 'sh')
conflicts=('bash')
backup=(etc/bash.bash{rc,_logout} etc/skel/.bash{rc,_profile,_logout})
source=("git+https://git.savannah.gnu.org/git/bash.git#branch=devel"
@@ -35,9 +35,10 @@ sha256sums=('SKIP'
pkgver() {
cd "bash"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^bash-[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^bash-//'
}
build() {