summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEden Rose2017-09-11 17:45:58 -0400
committerEden Rose2017-09-11 17:45:58 -0400
commit5117c08e5c3f47abede17944dfb8a7577fb94f0c (patch)
treef303dbbe22d048fc79ca7795aac5f32b172b62b5
downloadaur-5117c08e5c3f47abede17944dfb8a7577fb94f0c.tar.gz
Built sucessfully 91117. ncurses-full, provides missing libtinfo.a
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD80
-rw-r--r--bash.install16
-rw-r--r--dot.bash_logout3
-rw-r--r--dot.bash_profile5
-rw-r--r--dot.bashrc9
-rw-r--r--system.bash_logout3
-rw-r--r--system.bashrc22
8 files changed, 175 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3710e7c9a9a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = bash-devel-static-git
+ pkgdesc = The GNU Bourne Again shell (development version)(Static-Version)
+ pkgver = 4.0.alpha.r536.ga27e6ec3
+ pkgrel = 1
+ url = http://www.gnu.org/software/bash/bash.html
+ arch = i686
+ arch = x86_64
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = glibc
+ depends = ncurses
+ depends = libncursesw.a
+ optdepends = bash-completion: for tab completion
+ provides = sh
+ provides = bash=4.4
+ conflicts = bash
+ backup = etc/bash.bashrc
+ backup = etc/bash.bash_logout
+ backup = etc/skel/.bashrc
+ backup = etc/skel/.bash_profile
+ backup = etc/skel/.bash_logout
+ source = git+https://git.savannah.gnu.org/git/bash.git#branch=devel
+ source = dot.bashrc
+ source = dot.bash_profile
+ source = dot.bash_logout
+ source = system.bashrc
+ source = system.bash_logout
+ md5sums = SKIP
+ md5sums = 027d6bd8f5f6a06b75bb7698cb478089
+ md5sums = 2902e0fee7a9168f3a4fd2ccd60ff047
+ md5sums = 42f4400ed2314bd7519c020d0187edc5
+ md5sums = d8f3f334e72c0e30032eae1a1229aef1
+ md5sums = 472f536d7c9e8250dc4568ec4cfaf294
+
+pkgname = bash-devel-static-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..082ec3d4dc5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# $Id$
+# Maintainer: Eden Rose(endlesseden) <eenov1988 "at" gmail.com >
+# Contributor: Alad Wenter <alad@mailbox.org>
+# Contributor: Carlos Pita <carlosjosepita@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Aaron Griffin <aaron@archlinux.org>
+
+pkgname=bash-devel-static-git
+pkgdesc='The GNU Bourne Again shell (development version)(Static-Version)'
+pkgver=4.0.alpha.r536.ga27e6ec3
+pkgrel=1
+url='http://www.gnu.org/software/bash/bash.html'
+arch=('i686' 'x86_64' 'any')
+license=('GPL')
+backup=(etc/bash.bash{rc,_logout} etc/skel/.bash{rc,_profile,_logout})
+depends=('glibc' 'ncurses' 'libncursesw.a')
+makedepends=('git')
+optdepends=('bash-completion: for tab completion')
+provides=('sh' 'bash=4.4')
+conflicts=('bash')
+source=('git+https://git.savannah.gnu.org/git/bash.git#branch=devel'
+ 'dot.bashrc'
+ 'dot.bash_profile'
+ 'dot.bash_logout'
+ 'system.bashrc'
+ 'system.bash_logout')
+md5sums=('SKIP'
+ '027d6bd8f5f6a06b75bb7698cb478089'
+ '2902e0fee7a9168f3a4fd2ccd60ff047'
+ '42f4400ed2314bd7519c020d0187edc5'
+ 'd8f3f334e72c0e30032eae1a1229aef1'
+ '472f536d7c9e8250dc4568ec4cfaf294')
+
+pkgver() {
+ cd bash
+ git describe --long --tags | sed -e 's/bash.//' -e 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd bash
+ _bashconfig=(-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/bin\"\'
+ -DSTANDARD_UTILS_PATH=\'\"/usr/bin\"\'
+ -DSYS_BASHRC=\'\"/etc/bash.bashrc\"\'
+ -DSYS_BASH_LOGOUT=\'\"/etc/bash.bash_logout\"\')
+ export CFLAGS="${CFLAGS} ${_bashconfig[@]}"
+
+ ./configure --prefix=/usr --with-curses --enable-readline \
+ --with-gnu-malloc --enable-mem-scramble --enable-usg-echo-default \
+ --enable-single-help-strings --enable-select \
+ --enable-restricted --enable-progcomp --enable-process-substitution \
+ --enable-net-redirections --enable-multibyte --enable-job-control \
+ --enable-history --enable-help-builtin --enable-dparen-arithmetic \
+ --enable-directory-stack --enable-coprocesses --enable-cond-regexp \
+ --enable-cond-command --enable-command-timing --enable-casemod-expansions \
+ --enable-casemod-attributes --enable-brace-expansion --enable-bang-history \
+ --enable-array-variables --enable-arith-for-command --enable-alias \
+ --enable-static-link
+ make
+}
+
+
+check() {
+ make -C bash check
+}
+
+package() {
+ make -C bash DESTDIR="$pkgdir" install
+ ln -s bash "$pkgdir"/usr/bin/sh
+ install -dm755 "$pkgdir"/etc/skel
+
+ # system-wide configuration files
+ install -m644 system.bashrc $pkgdir/etc/bash.bashrc
+ install -m644 system.bash_logout "$pkgdir"/etc/bash.bash_logout
+
+ # user configuration file skeletons
+ install -m644 dot.bashrc "$pkgdir"/etc/skel/.bashrc
+ install -m644 dot.bash_profile "$pkgdir"/etc/skel/.bash_profile
+ install -m644 dot.bash_logout "$pkgdir"/etc/skel/.bash_logout
+}
diff --git a/bash.install b/bash.install
new file mode 100644
index 000000000000..a10e6e909a66
--- /dev/null
+++ b/bash.install
@@ -0,0 +1,16 @@
+info_dir=usr/share/info
+info_files=(bash.info)
+
+post_upgrade() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for f in ${info_files[@]}; do
+ usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
+ done
+}
diff --git a/dot.bash_logout b/dot.bash_logout
new file mode 100644
index 000000000000..0e4e4f1845f2
--- /dev/null
+++ b/dot.bash_logout
@@ -0,0 +1,3 @@
+#
+# ~/.bash_logout
+#
diff --git a/dot.bash_profile b/dot.bash_profile
new file mode 100644
index 000000000000..5545f007ea9b
--- /dev/null
+++ b/dot.bash_profile
@@ -0,0 +1,5 @@
+#
+# ~/.bash_profile
+#
+
+[[ -f ~/.bashrc ]] && . ~/.bashrc
diff --git a/dot.bashrc b/dot.bashrc
new file mode 100644
index 000000000000..a355b0cd3267
--- /dev/null
+++ b/dot.bashrc
@@ -0,0 +1,9 @@
+#
+# ~/.bashrc
+#
+
+# If not running interactively, don't do anything
+[[ $- != *i* ]] && return
+
+alias ls='ls --color=auto'
+PS1='[\u@\h \W]\$ '
diff --git a/system.bash_logout b/system.bash_logout
new file mode 100644
index 000000000000..a76e48e4ae67
--- /dev/null
+++ b/system.bash_logout
@@ -0,0 +1,3 @@
+#
+# /etc/bash.bash_logout
+#
diff --git a/system.bashrc b/system.bashrc
new file mode 100644
index 000000000000..c484b2bc7716
--- /dev/null
+++ b/system.bashrc
@@ -0,0 +1,22 @@
+#
+# /etc/bash.bashrc
+#
+
+# If not running interactively, don't do anything
+[[ $- != *i* ]] && return
+
+[[ $DISPLAY ]] && shopt -s checkwinsize
+
+PS1='[\u@\h \W]\$ '
+
+case ${TERM} in
+ xterm*|rxvt*|Eterm|aterm|kterm|gnome*)
+ PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
+
+ ;;
+ screen*)
+ PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033_%s@%s:%s\033\\" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
+ ;;
+esac
+
+[ -r /usr/share/bash-completion/bash_completion ] && . /usr/share/bash-completion/bash_completion