summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRémi Audebert2016-05-19 23:00:14 -0700
committerRémi Audebert2016-05-19 23:00:14 -0700
commit02a6ee6e5336bfbee85f04e3e29851c631a4895f (patch)
treef0efb195b7fde661f3d98e2af163c41c2c3e7dd3
downloadaur-bash-eternal-history.tar.gz
Initial import of bash-eternal-history
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--bash-eternal-history.sh7
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35a7b86a8b26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = bash-eternal-history
+ pkgdesc = Configure bash to track all the executed commands
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ license = WTFPL
+ depends = bash
+ source = bash-eternal-history.sh
+ md5sums = fa7c811bd49ce7f5e7f2de1e36dc859f
+
+pkgname = bash-eternal-history
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81fdb25b53c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,14 @@
+# Maintainer: Rémi Audebert <rflah0+aur@gmail.com>
+pkgname=bash-eternal-history
+pkgver=1
+pkgrel=1
+pkgdesc="Configure bash to track all the executed commands"
+arch=('any')
+license=('WTFPL')
+depends=('bash')
+source=("$pkgname.sh")
+md5sums=('fa7c811bd49ce7f5e7f2de1e36dc859f')
+
+package() {
+ install $srcdir/$pkgname.sh -D --target-directory $pkgdir/etc/profile.d/
+}
diff --git a/bash-eternal-history.sh b/bash-eternal-history.sh
new file mode 100644
index 000000000000..177898d66a2e
--- /dev/null
+++ b/bash-eternal-history.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+export HISTTIMEFORMAT='%d/%m/%y %T '
+export HISTSIZE=-1
+export HISTFILESIZE=-1
+export HISTFILE=~/.bash_eternal_history
+export PROMPT_COMMAND="history -a; $PROMPT_COMMAND"