summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-07-20 01:49:49 +0100
committerJoão Figueiredo2021-07-20 01:49:49 +0100
commit7c17008bf70708c559bc5caf803b53a8bd5dcdbb (patch)
treeb66c5f985fd01db0769f57387218449650524aa0
downloadaur-7c17008bf70708c559bc5caf803b53a8bd5dcdbb.tar.gz
Merged with official ABS bash PKGBUILD
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD81
-rw-r--r--dot.bash_logout3
-rw-r--r--dot.bash_profile5
-rw-r--r--dot.bashrc9
-rw-r--r--system.bash_logout3
-rw-r--r--system.bashrc22
7 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..397b698988bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = bash-git
+ pkgdesc = The GNU Bourne Again shell
+ pkgver = 5.1_r171.gce237286
+ pkgrel = 1
+ url = https://www.gnu.org/software/bash/bash.html
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = readline
+ depends = libreadline.so
+ depends = glibc
+ depends = ncurses
+ optdepends = bash-completion: for tab completion
+ provides = sh
+ backup = etc/bash.bashrc
+ backup = etc/bash.bash_logout
+ backup = etc/skel/.bashrc
+ backup = etc/skel/.bash_profile
+ backup = etc/skel/.bash_logout
+ source = git+https://git.savannah.gnu.org/git/bash.git
+ source = dot.bashrc
+ source = dot.bash_profile
+ source = dot.bash_logout
+ source = system.bashrc
+ source = system.bash_logout
+ sha256sums = SKIP
+ sha256sums = 3e22bf86ae6708df7a6bceb88c67a00118275f9c0b5268f453dd388af7c43b53
+ sha256sums = e149407c2bee17779caec70a7edd3d0000d172e7e4347429b80cb4d55bcec9c2
+ sha256sums = 4330edf340394d0dae50afb04ac2a621f106fe67fb634ec81c4bfb98be2a1eb5
+ sha256sums = 5fdc20c44bc9058f728d11111327f4dbb5598fec4d948dd5265211598667f9f0
+ sha256sums = 025bccfb374a3edce0ff8154d990689f30976b78f7a932dc9a6fcef81821811e
+
+pkgname = bash-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f00aeca89e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Merged with official ABS bash PKGBUILD by João, 2021/07/19 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <islandc0der@chaotic.cx>
+
+pkgname=bash-git
+pkgver=5.1_r171.gce237286
+pkgrel=1
+pkgdesc='The GNU Bourne Again shell'
+arch=($CARCH)
+license=(GPL)
+url='https://www.gnu.org/software/bash/bash.html'
+backup=(etc/bash.bash{rc,_logout} etc/skel/.bash{rc,_profile,_logout})
+depends=(readline libreadline.so glibc ncurses)
+makedepends=(git)
+optdepends=('bash-completion: for tab completion')
+provides=('sh')
+source=(git+https://git.savannah.gnu.org/git/bash.git
+ dot.bashrc
+ dot.bash_profile
+ dot.bash_logout
+ system.bashrc
+ system.bash_logout)
+sha256sums=('SKIP'
+ '3e22bf86ae6708df7a6bceb88c67a00118275f9c0b5268f453dd388af7c43b53'
+ 'e149407c2bee17779caec70a7edd3d0000d172e7e4347429b80cb4d55bcec9c2'
+ '4330edf340394d0dae50afb04ac2a621f106fe67fb634ec81c4bfb98be2a1eb5'
+ '5fdc20c44bc9058f728d11111327f4dbb5598fec4d948dd5265211598667f9f0'
+ '025bccfb374a3edce0ff8154d990689f30976b78f7a932dc9a6fcef81821811e')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 '@set VERSION' doc/version.texi | cut -d ' ' -f3 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+# prepare() {
+# wget -q --show-progress --no-parent -nd -r https://ftp.gnu.org/gnu/bash/bash-$pkgver-patches/
+# rm *.sig
+#
+# cd ${pkgname%-git}
+# for patch in ../bash${pkgver//.}*; do
+# patch -p0 -i $patch
+# done
+# }
+
+build() {
+ cd ${pkgname%-git}
+
+ _bashconfig=(-DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/bin\"\'
+ -DSTANDARD_UTILS_PATH=\'\"/usr/bin\"\'
+ -DSYS_BASHRC=\'\"/etc/bash.bashrc\"\'
+ -DSYS_BASH_LOGOUT=\'\"/etc/bash.bash_logout\"\'
+ -DNON_INTERACTIVE_LOGIN_SHELLS)
+ export CFLAGS="${CFLAGS} ${_bashconfig[@]}"
+
+ ./configure \
+ --prefix=/usr \
+ --with-curses \
+ --enable-readline \
+ --without-bash-malloc \
+ --with-installed-readline
+ make
+}
+
+# check() {
+# make -C ${pkgname%-git} check
+# }
+
+package() {
+ make -C ${pkgname%-git} DESTDIR="$pkgdir" install
+ ln -s bash "$pkgdir/usr/bin/sh"
+
+ # system-wide configuration files
+ install -Dm644 system.bashrc "$pkgdir/etc/bash.bashrc"
+ install -Dm644 system.bash_logout "$pkgdir/etc/bash.bash_logout"
+
+ # user configuration file skeletons
+ install -dm755 "$pkgdir/etc/skel/"
+ install -m644 dot.bashrc "$pkgdir/etc/skel/.bashrc"
+ install -m644 dot.bash_profile "$pkgdir/etc/skel/.bash_profile"
+ install -m644 dot.bash_logout "$pkgdir/etc/skel/.bash_logout"
+}
diff --git a/dot.bash_logout b/dot.bash_logout
new file mode 100644
index 000000000000..0e4e4f1845f2
--- /dev/null
+++ b/dot.bash_logout
@@ -0,0 +1,3 @@
+#
+# ~/.bash_logout
+#
diff --git a/dot.bash_profile b/dot.bash_profile
new file mode 100644
index 000000000000..5545f007ea9b
--- /dev/null
+++ b/dot.bash_profile
@@ -0,0 +1,5 @@
+#
+# ~/.bash_profile
+#
+
+[[ -f ~/.bashrc ]] && . ~/.bashrc
diff --git a/dot.bashrc b/dot.bashrc
new file mode 100644
index 000000000000..a355b0cd3267
--- /dev/null
+++ b/dot.bashrc
@@ -0,0 +1,9 @@
+#
+# ~/.bashrc
+#
+
+# If not running interactively, don't do anything
+[[ $- != *i* ]] && return
+
+alias ls='ls --color=auto'
+PS1='[\u@\h \W]\$ '
diff --git a/system.bash_logout b/system.bash_logout
new file mode 100644
index 000000000000..a76e48e4ae67
--- /dev/null
+++ b/system.bash_logout
@@ -0,0 +1,3 @@
+#
+# /etc/bash.bash_logout
+#
diff --git a/system.bashrc b/system.bashrc
new file mode 100644
index 000000000000..c484b2bc7716
--- /dev/null
+++ b/system.bashrc
@@ -0,0 +1,22 @@
+#
+# /etc/bash.bashrc
+#
+
+# If not running interactively, don't do anything
+[[ $- != *i* ]] && return
+
+[[ $DISPLAY ]] && shopt -s checkwinsize
+
+PS1='[\u@\h \W]\$ '
+
+case ${TERM} in
+ xterm*|rxvt*|Eterm|aterm|kterm|gnome*)
+ PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033]0;%s@%s:%s\007" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
+
+ ;;
+ screen*)
+ PROMPT_COMMAND=${PROMPT_COMMAND:+$PROMPT_COMMAND; }'printf "\033_%s@%s:%s\033\\" "${USER}" "${HOSTNAME%%.*}" "${PWD/#$HOME/\~}"'
+ ;;
+esac
+
+[ -r /usr/share/bash-completion/bash_completion ] && . /usr/share/bash-completion/bash_completion