summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2018-10-09 08:54:22 +0200
committerClaudia2018-10-09 08:54:46 +0200
commit28094eb9aa7ab086b4d16f2cc3a1e7c5c364320f (patch)
tree9279d37e4986465053a26422f8fef69455bfb8dc
parent2993a1dd4a0e4a2bd58074e7724e874357bb855e (diff)
downloadaur-28094eb9aa7ab086b4d16f2cc3a1e7c5c364320f.tar.gz
Add Markdown document, explain legacy symlinks
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6def628b884b..b0a6ccce5068 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bash-it-git
pkgdesc = A community Bash framework
- pkgver = r1842.acb98c3
+ pkgver = r2279.36345cb
pkgrel = 1
url = https://github.com/Bash-it/bash-it
install = bash-it-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 087dc0242814..684d054baaa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# PKGBUILD reference: https://wiki.archlinux.org/index.php/PKGBUILD
pkgname=bash-it-git
-pkgver=r1842.acb98c3
+pkgver=r2279.36345cb
pkgrel=1
pkgdesc='A community Bash framework'
arch=('any')
@@ -110,7 +110,16 @@ package() {
_factorydir="${pkgdir}/usr/share/${pkgname}/home_factory/.bash_it"
# For aliases, completions, and plugins, create symlinks
- # to the respective `available` directories
+ # to the respective `${_file_type}/available` directories
+ # because earlier versions of Bash-it used to place enabled
+ # symlinks into `${_file_type}/enabled`, to which the user
+ # would have needed write permissions.
+ # Newer Bash-it installs will place all symlinks into
+ # a common, top-level `enabled` directory, and will no
+ # longer use `${_file_type}/enabled` directories.
+ # We keep the below symlinks around in order to protect
+ # legacy installations, whose users may have non-empty
+ # `${_file_type}/enabled` directories.
for _file_type in aliases completion plugins; do
mkdir -p "${_factorydir}/${_file_type}"
ln -fns "/usr/lib/${pkgname}/${_file_type}/available" \
@@ -130,6 +139,6 @@ package() {
"/usr/lib/${pkgname}"/{bash_it,install,uninstall}.sh \
"/usr/lib/${pkgname}"/{lib,themes} \
"/usr/share/${pkgname}"/{.editorconfig,template} \
- "/usr/share/doc/${pkgname}"/{CONTRIBUTING,README}.md \
+ "/usr/share/doc/${pkgname}"/{CONTRIBUTING,DEVELOPMENT,README}.md \
"${_factorydir}/"
}