summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2021-11-23 10:22:30 +0100
committerClaudia Pellegrino2021-11-23 10:22:30 +0100
commit747028d30eed49c6681c3741d51ce3116ba1c57e (patch)
treed00e1c44ca634e8d54a1fe43a60384872a263523
parent47953ee60cb3e038d87633d337184bf44261462b (diff)
downloadaur-747028d30eed49c6681c3741d51ce3116ba1c57e.tar.gz
Update .gitignore, add .editorconfig
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore4
2 files changed, 24 insertions, 0 deletions
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..cf06dd3ed5ab
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[.gitattributes]
+indent_size = 16
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
index 6ea6bed05321..3ac3585221a6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,5 @@
+/.vscode
/bash-it-git
+/src
+/pkg
+*.tar.*