summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2017-05-06 14:48:18 +0200
committerClaudia Pellegrino2017-06-18 16:39:37 +0200
commitf7b52ea2412ca631611affa1ab0797a622720764 (patch)
tree680f46c57736706b8f8b9b9e2a3151ee82dc26f5
parent051379dbf161e22a96f5be0936797acc81258f2f (diff)
downloadaur-f7b52ea2412ca631611affa1ab0797a622720764.tar.gz
Remove `pkgdir` prefix from symlink sources
-rw-r--r--PKGBUILD28
1 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f01cf5baa180..f5cc03c8f0e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,9 +63,11 @@ package() {
for _file_type in aliases completion plugins; do
mkdir -p "${_templatedir}/${_file_type}/available"
- ln -fs \
- "${pkgdir}/usr/lib/${pkgname}/${_file_type}/available"/* \
- "${_templatedir}/${_file_type}/available/"
+ for _available_module \
+ in "${pkgdir}/usr/lib/${pkgname}/${_file_type}/available"/*; do
+ ln -fs "/${_available_module#${pkgdir}}" \
+ "${_templatedir}/${_file_type}/available/"
+ done
done
cp --preserve=mode -t "${_templatedir}" \
@@ -74,19 +76,23 @@ package() {
mkdir -p "${_templatedir}"/{custom,lib,template,themes}
ln -fs \
- "${pkgdir}/usr/lib/${pkgname}"/{bash_it,install,uninstall}.sh \
- "${pkgdir}/usr/share/doc/${pkgname}"/* \
+ "/usr/lib/${pkgname}"/{bash_it,install,uninstall}.sh \
+ "/usr/share/doc/${pkgname}"/{CONTRIBUTING,README}.md \
"${_templatedir}/"
for _customizable_dir in custom lib themes; do
- ln -fs \
- "${pkgdir}/usr/lib/${pkgname}/${_customizable_dir}"/* \
- "${_templatedir}/${_customizable_dir}/"
+ for _built_in_module \
+ in "${pkgdir}/usr/lib/${pkgname}/${_customizable_dir}"/*; do
+ ln -fs "/${_built_in_module#${pkgdir}}" \
+ "${_templatedir}/${_customizable_dir}/"
+ done
done
- ln -fs \
- "${pkgdir}/usr/share/${pkgname}/template"/* \
- "${_templatedir}/template/"
+ for _template \
+ in "${pkgdir}/usr/share/${pkgname}/template"/*; do
+ ln -fs "/${_template#${pkgdir}}" \
+ "${_templatedir}/template/"
+ done
cp -r --preserve=mode -t ~/ "${_templatedir}"
}