summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2020-05-09 15:53:30 +0200
committerLinus Dierheimer2020-05-09 15:53:30 +0200
commit41c425db55176a213ab80f69e8838745476d48af (patch)
treed2cc1b51be0c4d392ebb0894a89cd40825bd4677
parent0c12e060c5f1534d8a07f033d40823528bc936e9 (diff)
downloadaur-41c425db55176a213ab80f69e8838745476d48af.tar.gz
conflict with pipes.sh
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d4b30528296..59f14e071791 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = bash-pipes
- pkgdesc = Pipes screensaver for bash
+ pkgdesc = pipes.sh with a better name
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pipeseroni/pipes.sh
arch = any
license = MIT
depends = bash
+ provides = pipes.sh
+ conflicts = pipes.sh=1.3.0
source = https://github.com/pipeseroni/pipes.sh/archive/v1.3.0.tar.gz
sha256sums = 532976dd8dc2d98330c45a8bcb6d7dc19e0b0e30bba8872dcce352361655a426
diff --git a/PKGBUILD b/PKGBUILD
index 36fa0074a3c1..fbe523d11c82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,34 @@
pkgname=bash-pipes
pkgver=1.3.0
-pkgrel=2
-pkgdesc="Pipes screensaver for bash"
+pkgrel=3
+pkgdesc="pipes.sh with a better name"
arch=("any")
url="https://github.com/pipeseroni/pipes.sh"
license=("MIT")
depends=("bash")
source=("https://github.com/pipeseroni/pipes.sh/archive/v${pkgver}.tar.gz")
sha256sums=("532976dd8dc2d98330c45a8bcb6d7dc19e0b0e30bba8872dcce352361655a426")
+provides=("pipes.sh")
+conflicts=("pipes.sh=1.3.0")
+
+_alternative_names=(
+ "pipes"
+ "bash-pipes"
+)
+
package() {
cd "${srcdir}/pipes.sh-${pkgver}"
- make DESTDIR="$pkgdir" PREFIX=/usr install
- #contain backwards compatibility with old aur versions
- ln -sf "/usr/bin/pipes.sh" "${pkgdir}/usr/bin/pipes"
- ln -sf "/usr/bin/pipes.sh" "${pkgdir}/usr/bin/bash-pipes"
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+ install -Dm644 -t "${pkgdir}/usr/share/doc/pipes.sh" LICENSE
+ install -Dm644 -t "${pkgdir}/usr/share/doc/pipes.sh" README.rst
- ln -sf "/usr/share/man/man6/pipes.sh.6.gz" "${pkgdir}/usr/share/man/man6/pipes.6.gz"
- ln -sf "/usr/share/man/man6/pipes.sh.6.gz" "${pkgdir}/usr/share/man/man6/bash-pipes.6.gz"
+ #Cooler names and backwards compatibility with old bash-pipes
+ for name in "${_alternative_names[@]}"
+ do
+ ln -sf "/usr/bin/pipes.sh" "${pkgdir}/usr/bin/${name}"
+ ln -sf "/usr/share/man/man6/pipes.sh.6.gz" "${pkgdir}/usr/share/man/man6/${name}.6.gz"
+ ln -sf "/usr/share/doc/pipes.sh" "${pkgdir}/usr/share/doc/${name}"
+ done
}