summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2020-05-09 14:57:03 +0200
committerLinus Dierheimer2020-05-09 14:57:03 +0200
commit6784da6465171066eb2026aff7fed0454b2a8197 (patch)
tree7b22303a5c77c47e0414fa1ad4cc9bef2b7f6d94
parent0d0ae9619b79f91d15e516351cb01eb0282501ba (diff)
downloadaur-6784da6465171066eb2026aff7fed0454b2a8197.tar.gz
upgraded to v1.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33a818fddf1b..2602e978a073 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bash-pipes
pkgdesc = Pipes screensaver for bash
- pkgver = 1.2
- pkgrel = 2
- url = http://acidhub.github.io/pipes.sh
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/pipeseroni/pipes.sh
arch = any
- license = GPL
+ license = MIT
depends = bash
- source = https://github.com/Acidhub/pipes.sh/archive/v1.2.tar.gz
- sha512sums = 88e2457f5072c4d13e9afc44964e75b84b0bcee3d80cd439e9ca733ca0d2108fbd998bbd73c5333679b42a6681b68e0193c7ff707070163de93e527994fe0d96
+ source = https://github.com/pipeseroni/pipes.sh/archive/v1.3.0.tar.gz
+ sha256sums = 532976dd8dc2d98330c45a8bcb6d7dc19e0b0e30bba8872dcce352361655a426
pkgname = bash-pipes
diff --git a/PKGBUILD b/PKGBUILD
index b2d4dc36c7d8..d3f409afaaba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: AcidHub <contact@acidhub.click>
+# Maintainer: LinusDierheimer <Linus@Dierheimer.de>
pkgname=bash-pipes
-pkgver=1.2
-pkgrel=2
-pkgdesc='Pipes screensaver for bash'
-arch=('any')
-url='http://acidhub.github.io/pipes.sh'
-license=('GPL')
-depends=('bash')
-source=("https://github.com/Acidhub/pipes.sh/archive/v$pkgver.tar.gz")
-sha512sums=('88e2457f5072c4d13e9afc44964e75b84b0bcee3d80cd439e9ca733ca0d2108fbd998bbd73c5333679b42a6681b68e0193c7ff707070163de93e527994fe0d96')
-
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Pipes screensaver for bash"
+arch=("any")
+url="https://github.com/pipeseroni/pipes.sh"
+license=("MIT")
+depends=("bash")
+source=("https://github.com/pipeseroni/pipes.sh/archive/v${pkgver}.tar.gz")
+sha256sums=("532976dd8dc2d98330c45a8bcb6d7dc19e0b0e30bba8872dcce352361655a426")
package() {
- cd pipes.sh-$pkgver
+ cd "pipes.sh-${pkgver}"
make DESTDIR="$pkgdir" PREFIX=/usr install
+
+ #contain backwards compatibility with old aur versions
+ ln -sf "/usr/bin/pipes.sh" "${pkgdir}/usr/bin/pipes"
+ ln -sf "/usr/bin/pipes.sh" "${pkgdir}/usr/bin/bash-pipes"
}