summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Dierheimer2020-05-09 21:40:00 +0200
committerLinus Dierheimer2020-05-09 21:40:00 +0200
commite46b622103a5044dcac673724f692f51b7179032 (patch)
tree2b3dc323dd5ca53d21ccf701d8d0d794cc8ed84b
parent04ea815ebad15346a33b3ca0df1857c6c892b2e8 (diff)
downloadaur-e46b622103a5044dcac673724f692f51b7179032.tar.gz
depend on pipes.sh to avoid code duplication
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 10 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeb87af19580..5dc680d1e11b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = bash-pipes
pkgdesc = pipes.sh (animated pipes terminal screensaver) with additional better names (soft links)
pkgver = 1.3.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/pipeseroni/pipes.sh
arch = any
license = MIT
- depends = bash
- provides = pipes.sh=1.3.0
- conflicts = pipes.sh
- source = https://github.com/pipeseroni/pipes.sh/archive/v1.3.0.tar.gz
- sha256sums = 532976dd8dc2d98330c45a8bcb6d7dc19e0b0e30bba8872dcce352361655a426
+ depends = pipes.sh=1.3.0
pkgname = bash-pipes
diff --git a/PKGBUILD b/PKGBUILD
index 848158142bd3..7bfc3505afeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,24 @@
pkgname=bash-pipes
pkgver=1.3.0
-pkgrel=6
+pkgrel=7
pkgdesc="pipes.sh (animated pipes terminal screensaver) with additional better names (soft links)"
arch=("any")
url="https://github.com/pipeseroni/pipes.sh"
license=("MIT")
-depends=("bash")
-source=("https://github.com/pipeseroni/pipes.sh/archive/v${pkgver}.tar.gz")
-sha256sums=("532976dd8dc2d98330c45a8bcb6d7dc19e0b0e30bba8872dcce352361655a426")
-provides=("pipes.sh=1.3.0")
-conflicts=("pipes.sh")
+depends=("pipes.sh=${pkgver}")
+source=()
_alternative_names=(
- "pipes"
- "bash-pipes"
+ "pipes" # backwards compatibility with old bash-pipes
+ "bash-pipes" # personally, i like this name
)
package() {
- cd "${srcdir}/pipes.sh-${pkgver}"
+ mkdir -p "${pkgdir}/usr/bin/"
+ mkdir -p "${pkgdir}/usr/share/man/man6/"
+ mkdir -p "${pkgdir}/usr/share/doc/"
- make DESTDIR="${pkgdir}" PREFIX=/usr install
- install -Dm644 -t "${pkgdir}/usr/share/doc/pipes.sh" LICENSE
- install -Dm644 -t "${pkgdir}/usr/share/doc/pipes.sh" README.rst
-
- #Cooler names and backwards compatibility with old bash-pipes
for name in "${_alternative_names[@]}"
do
ln -sf "/usr/bin/pipes.sh" "${pkgdir}/usr/bin/${name}"