summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Bouvet2020-09-27 22:01:15 +0200
committerQuentin Bouvet2020-09-27 22:01:15 +0200
commit4750fde1fb1fafdc6badf7801ec0dc6c9075c634 (patch)
tree23d549c45f23a529f07382e713e232ca65273600
parentf98788676d2b0790ec630f913a73120e5c7184e1 (diff)
downloadaur-4750fde1fb1fafdc6badf7801ec0dc6c9075c634.tar.gz
Static git release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--bash-timer.install7
3 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23b481232249..26fa9c0aedf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = bash-timer
pkgdesc = Human-readable execution time for every command in bash!
- pkgver = v1.1.0.r0.g35040fb
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/hopeseekr/bash-timer
install = bash-timer.install
arch = any
license = APACHE
depends = bash-preexec-git
- source = bash-timer::git+https://github.com/hopeseekr/bash-timer.git
- md5sums = SKIP
+ source = bash-timer-1.1.0::https://github.com/hopeseekr/bash-timer/archive/v1.1.0.tar.gz
+ sha256sums = 75e16d41893074c2f57cb2c8dff1e04c8dc74dd8f43ee3917f9a48982d040753
pkgname = bash-timer
diff --git a/PKGBUILD b/PKGBUILD
index 98aba91a5928..5d33323ae402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Quentin Bouvet <qbouvet at outlook dot com>
pkgname=bash-timer
-pkgver=v1.1.0.r0.g35040fb
+pkgver=1.1.0
pkgrel=1
pkgdesc="Human-readable execution time for every command in bash!"
arch=('any')
url="https://github.com/hopeseekr/bash-timer"
license=('APACHE')
-
depends=('bash-preexec-git')
-#makedepends=()
-source=("$pkgname::git+https://github.com/hopeseekr/bash-timer.git")
-install=$pkgname.install
-md5sums=('SKIP')
-pkgver() {
- cd "$srcdir/${pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+source=("${pkgname}-${pkgver}::https://github.com/hopeseekr/bash-timer/archive/v${pkgver}.tar.gz")
+install=${pkgname}.install
+sha256sums=('75e16d41893074c2f57cb2c8dff1e04c8dc74dd8f43ee3917f9a48982d040753')
package() {
- cd "$srcdir/$pkgname"
- install -D -m0755 "$srcdir/$pkgname/bash-timer.sh" "$pkgdir/usr/share/bash-timer/bash-timer.sh"
+ cd "${srcdir}/"
+ install -D -m0755 -t "${pkgdir}/usr/share/${pkgname}" \
+ "${pkgname}-${pkgver}/${pkgname}.sh"
}
+
+#
+# makepkg --printsrcinfo > .SRCINFO
+#
diff --git a/bash-timer.install b/bash-timer.install
index 819859cee66a..a4ecca934657 100644
--- a/bash-timer.install
+++ b/bash-timer.install
@@ -10,12 +10,11 @@ post_install() {
> # Define timer callback functions
> [[ -f $bash_timer_path ]] && source $bash_timer_path
> # Register callback functions with bash-preexec
-> [[ -f $preexec_path ]] && source $preexec_path
+> [[ -f $preexec_path ]] && source $preexec_path
>
-$ echo \"#\n# bash-timer\n#\" >> /etc/bash.bashrc
$ echo \"[[ -f $bash_timer_path ]] && source $bash_timer_path\" >> /etc/bash.bashrc
-$ echo \"[[ -f $preexec_path ]] && source $preexec_path\" >> /etc/bash.bashrc
+$ echo \"[[ -f $preexec_path ]] && source $preexec_path\" >> /etc/bash.bashrc
"
}
@@ -26,4 +25,4 @@ post_remove() {
> To complete removal, remove the 'source' directives from your bashrc.
>
"
-} \ No newline at end of file
+}