summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-08-21 05:10:30 -0400
committerJames An2014-08-21 05:10:30 -0400
commit25595db1a557ac49f7e1b080cdef3585cb52994c (patch)
tree55c1b3287242ee3e9dddc3b2c9265685b9f0ceee
downloadaur-25595db1a557ac49f7e1b080cdef3585cb52994c.tar.gz
Added new AUR package, bash-utils-git.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD79
-rw-r--r--python2.patch250
3 files changed, 349 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c48bdae7090b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = bash-utils-git
+ pkgdesc = Misc. small utilities mainly for bash
+ pkgver = r65.5861540
+ pkgrel = 1
+ url = https://github.com/jabbalaci/Bash-Utils
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python2
+ optdepends = markdown: for markdown.py
+ optdepends = pygtk: for mouse/mousepos_gui.py
+ optdepends = python2-beautifulsoup3: for get_images.py, get_links.py, and prettify.py
+ optdepends = python: for top10.py
+ source = bash-utils::git+https://github.com/jabbalaci/Bash-Utils.git
+ source = python2.patch
+ md5sums = SKIP
+ md5sums = 88dda86b5407a6aa7570d77c1de1054d
+
+pkgname = bash-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0411fae8f209
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,79 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=bash-utils-git
+pkgver=r62.51a4005
+pkgrel=1
+pkgdesc="Misc. small utilities mainly for bash"
+arch=('any')
+url="https://github.com/jabbalaci/Bash-Utils"
+license=('unknown')
+depends=(python2)
+optdepends=(
+ 'markdown: for markdown.py'
+ 'pygtk: for mouse/mousepos_gui.py'
+ 'python2-beautifulsoup3: for get_images.py, get_links.py, and prettify.py'
+ 'python: for top10.py'
+)
+makedepends=('git')
+source=(
+ 'bash-utils'::'git+https://github.com/jabbalaci/Bash-Utils.git'
+ 'python2.patch'
+)
+md5sums=(
+ 'SKIP'
+ '88dda86b5407a6aa7570d77c1de1054d'
+)
+
+pkgver() {
+ cd bash-utils
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd bash-utils
+ patch -p1 < ../python2.patch
+}
+
+package() {
+ cd bash-utils
+
+ # install the scripts
+ install -dm755 "${pkgdir}/usr/lib/bash-utils"
+ cp -R . "${pkgdir}/usr/lib/bash-utils"
+ find "$pkgdir" -type d -exec chmod 0755 {} +
+ find "$pkgdir" -type f -exec chmod 0644 {} +
+ find "$pkgdir" -name '*.p[ly]' -type f -exec chmod 0755 {} +
+ rm -rf "${pkgdir}/usr/lib/bash-utils/.git"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -st "${pkgdir}/usr/bin" \
+ /usr/lib/bash-utils/alarm.py \
+ /usr/lib/bash-utils/dictionary/dictionary.py \
+ /usr/lib/bash-utils/dropbox/dropbox_permissions.py \
+ /usr/lib/bash-utils/dropbox/get_public_link.py \
+ /usr/lib/bash-utils/firefox/export_firefox_cookies.py \
+ /usr/lib/bash-utils/get_images.py \
+ /usr/lib/bash-utils/get_links.py \
+ /usr/lib/bash-utils/img_to_base64.py \
+ /usr/lib/bash-utils/markdown.py \
+ /usr/lib/bash-utils/mouse/mousepos_gui.py \
+ /usr/lib/bash-utils/open_in_tabs.py \
+ /usr/lib/bash-utils/prettify.py \
+ /usr/lib/bash-utils/py2rtf.py \
+ /usr/lib/bash-utils/radio/radio.py \
+ /usr/lib/bash-utils/reddit/reddit_get_posts.py \
+ /usr/lib/bash-utils/redirect_to.py \
+ /usr/lib/bash-utils/replace_accents/replace_french_accents_to_latex.pl \
+ /usr/lib/bash-utils/replace_accents/replace_latex_accents.pl \
+ /usr/lib/bash-utils/sp.py \
+ /usr/lib/bash-utils/templates/alap.py \
+ /usr/lib/bash-utils/tocb.py \
+ /usr/lib/bash-utils/top10.py \
+ /usr/lib/bash-utils/us.py
+}
+
+
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..56e5c9733b21
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,250 @@
+diff --git a/alarm.py b/alarm.py
+index 8477b6f..2b0d895 100755
+--- a/alarm.py
++++ b/alarm.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Alarm script
+diff --git a/dictionary/dictionary.py b/dictionary/dictionary.py
+index 2d3297a..0de5868 100755
+--- a/dictionary/dictionary.py
++++ b/dictionary/dictionary.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ A very simple lookup of a word.
+diff --git a/dropbox/dropbox_permissions.py b/dropbox/dropbox_permissions.py
+index 5db44b6..5c1e137 100755
+--- a/dropbox/dropbox_permissions.py
++++ b/dropbox/dropbox_permissions.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Setting file permissions in your Dropbox folder recursively
+diff --git a/dropbox/get_public_link.py b/dropbox/get_public_link.py
+index 5514a9b..e5fad9b 100755
+--- a/dropbox/get_public_link.py
++++ b/dropbox/get_public_link.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # encoding: utf-8
+
+ """
+diff --git a/firefox/export_firefox_cookies.py b/firefox/export_firefox_cookies.py
+index cb1c1c8..8cd4b26 100755
+--- a/firefox/export_firefox_cookies.py
++++ b/firefox/export_firefox_cookies.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Extract Firefox cookies
+diff --git a/get_alap.py b/get_alap.py
+index 2bf96bd..53aa4ca 100755
+--- a/get_alap.py
++++ b/get_alap.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import os
+ import sys
+diff --git a/get_images.py b/get_images.py
+index 478b5d7..a1cdae4 100755
+--- a/get_images.py
++++ b/get_images.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Extract image links from a web page
+diff --git a/get_links.py b/get_links.py
+index a8046d4..dc76de8 100755
+--- a/get_links.py
++++ b/get_links.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Extract all links from a web page
+diff --git a/img_to_base64.py b/img_to_base64.py
+index ac1c130..91ab1e4 100755
+--- a/img_to_base64.py
++++ b/img_to_base64.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Image to BASE64
+diff --git a/markdown.py b/markdown.py
+index 21312dc..ae63af0 100755
+--- a/markdown.py
++++ b/markdown.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Markdown previewer
+diff --git a/mouse/mousepos_gui.py b/mouse/mousepos_gui.py
+index a59f890..a96bbbf 100755
+--- a/mouse/mousepos_gui.py
++++ b/mouse/mousepos_gui.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Monitor the mouse position.
+diff --git a/open_in_tabs.py b/open_in_tabs.py
+index 102d5a0..3515deb 100755
+--- a/open_in_tabs.py
++++ b/open_in_tabs.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Open URLs in tabs
+diff --git a/prettify.py b/prettify.py
+index bc01b96..dc71e9b 100755
+--- a/prettify.py
++++ b/prettify.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # Website: https://pythonadventures.wordpress.com/2011/04/03/prettify-html-with-beautifulsoup/
+ # Laszlo Szathmary, 2011 (jabba.laci@gmail.com)
+diff --git a/py2rtf.py b/py2rtf.py
+index 1b01add..6f50913 100755
+--- a/py2rtf.py
++++ b/py2rtf.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ py2rtf
+diff --git a/radio/radio.py b/radio/radio.py
+index 991f7eb..78efa8d 100755
+--- a/radio/radio.py
++++ b/radio/radio.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Play online radio stations
+diff --git a/reddit/reddit_get_all_pages.py b/reddit/reddit_get_all_pages.py
+index c824561..5a2f2d6 100755
+--- a/reddit/reddit_get_all_pages.py
++++ b/reddit/reddit_get_all_pages.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Reddit, browse all pages of a subreddit
+diff --git a/reddit/reddit_get_posts.py b/reddit/reddit_get_posts.py
+index 19afbe7..9272042 100755
+--- a/reddit/reddit_get_posts.py
++++ b/reddit/reddit_get_posts.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Reddit, get posts
+diff --git a/reddit/reddit_top10.py b/reddit/reddit_top10.py
+index 0db4e0a..41dbaab 100755
+--- a/reddit/reddit_top10.py
++++ b/reddit/reddit_top10.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ """
+diff --git a/reddit/submit_to_reddit_gui/01_submit.py b/reddit/submit_to_reddit_gui/01_submit.py
+index f083f1f..582ffeb 100755
+--- a/reddit/submit_to_reddit_gui/01_submit.py
++++ b/reddit/submit_to_reddit_gui/01_submit.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ #Boa:Frame:Frame1
+
+diff --git a/reddit/submit_to_reddit_gui/config.py b/reddit/submit_to_reddit_gui/config.py
+index 6fa7e7b..21bab8d 100755
+--- a/reddit/submit_to_reddit_gui/config.py
++++ b/reddit/submit_to_reddit_gui/config.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ import os
+
+diff --git a/redirect_to.py b/redirect_to.py
+index 40b725f..c17dfb5 100755
+--- a/redirect_to.py
++++ b/redirect_to.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ """
+ Where does a URL redirect?
+diff --git a/sp.py b/sp.py
+index d304ddb..ef502f9 100755
+--- a/sp.py
++++ b/sp.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # Website: https://ubuntuincident.wordpress.com/2011/03/17/show-the-absolute-path-of-a-file/
+ # Laszlo Szathmary, 2011 (jabba.laci@gmail.com)
+diff --git a/templates/alap.py b/templates/alap.py
+index cbd6ea7..9772484 100644
+--- a/templates/alap.py
++++ b/templates/alap.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+
+ def main():
+diff --git a/tocb.py b/tocb.py
+index 5e501a9..5283d50 100755
+--- a/tocb.py
++++ b/tocb.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # Website: https://pythonadventures.wordpress.com/2011/03/05/copy-string-to-x-clipboards/
+ # Laszlo Szathmary, 2011--2012 (jabba.laci@gmail.com)
+diff --git a/us.py b/us.py
+index 980be68..8771961 100755
+--- a/us.py
++++ b/us.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+
+ # Change spaces to underscores.
+ # When to use: creating directories/files and we want to avoid spaces