summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Reisner2018-06-02 10:54:15 -0400
committerDave Reisner2018-06-02 10:54:15 -0400
commiteb0684d98e7fa6532ac2549b00acff8e82f1949c (patch)
tree4977509f93562d06ffbd70de27c6893f6efabc80
parentdeaab905b6efffd674c9a70c890d8999d3e9f3e5 (diff)
downloadaur-bash3.tar.gz
fix build, include all patches
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14304ff61462..493975796d0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bash3
pkgdesc = The GNU Bourne Again shell. Version 3.2. Binary and manpage only.
pkgver = 3.2.057
- pkgrel = 3
+ pkgrel = 4
url = http://www.gnu.org/software/bash/bash.html
arch = i686
arch = x86_64
@@ -60,6 +60,12 @@ pkgbase = bash3
source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-049
source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-050
source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-051
+ source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-052
+ source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-053
+ source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-054
+ source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-055
+ source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-056
+ source = http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-057
md5sums = 00bfa16d58e034e3c2aa27f390390d30
md5sums = d8e10c754f477e3f3a581af566b89301
md5sums = d38a5288b2f0ea6c9ac76b66cc74ef7d
@@ -112,6 +118,12 @@ pkgbase = bash3
md5sums = af571a2d164d5abdcae4499e94e8892c
md5sums = 8443d4385d73ec835abe401d90591377
md5sums = 15c6653042e9814aa87120098fc7a849
+ md5sums = 691023a944bbb9003cc92ad462d91fa1
+ md5sums = eb97d1c9230a55283d9dac69d3de2e46
+ md5sums = 1107744058c43b247f597584b88ba0a6
+ md5sums = 05d201176d3499e2dfa4a73d09d42f05
+ md5sums = 222eaa3a2c26f54a15aa5e08817a534a
+ md5sums = 47d98e3e042892495c5efe54ec6e5913
pkgname = bash3
diff --git a/PKGBUILD b/PKGBUILD
index b8438500bf99..3ba2789b07f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=bash3
_patchlevel=057
pkgver=3.2.$_patchlevel
-pkgrel=3
+pkgrel=4
pkgdesc="The GNU Bourne Again shell. Version 3.2. Binary and manpage only."
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.gnu.org/software/bash/bash.html"
depends=('readline' 'glibc')
source=("http://ftp.gnu.org/gnu/bash/bash-3.2.tar.gz"
- $(printf 'http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03d ' {1..51}))
+ $(printf 'http://ftp.gnu.org/gnu/bash/bash-3.2-patches/bash32-%03d ' {1..57}))
md5sums=('00bfa16d58e034e3c2aa27f390390d30'
'd8e10c754f477e3f3a581af566b89301'
'd38a5288b2f0ea6c9ac76b66cc74ef7d'
@@ -63,7 +63,13 @@ md5sums=('00bfa16d58e034e3c2aa27f390390d30'
'4cc593e7b789b23b37a5397e092d3954'
'af571a2d164d5abdcae4499e94e8892c'
'8443d4385d73ec835abe401d90591377'
- '15c6653042e9814aa87120098fc7a849')
+ '15c6653042e9814aa87120098fc7a849'
+ '691023a944bbb9003cc92ad462d91fa1'
+ 'eb97d1c9230a55283d9dac69d3de2e46'
+ '1107744058c43b247f597584b88ba0a6'
+ '05d201176d3499e2dfa4a73d09d42f05'
+ '222eaa3a2c26f54a15aa5e08817a534a'
+ '47d98e3e042892495c5efe54ec6e5913')
build() {
cd "$srcdir/bash-3.2"
@@ -74,6 +80,9 @@ build() {
./configure --prefix=/usr --with-curses --enable-readline \
--without-bash-malloc --with-installed-readline
+
+ sed -i '/HAVE_SETDTABLESIZE/d; /HAVE_SETOSTYPE/d' config.h
+
make
}