summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2015-06-25 11:08:38 +0300
committerChristoph Gysin2015-06-25 11:08:38 +0300
commitcef02f482b8f99192a27543114fdd07f94afa28c (patch)
tree634be584f7c51c65bbcd708a24c339368dea0208
downloadaur-cef02f482b8f99192a27543114fdd07f94afa28c.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD26
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13ccf9bec1c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bashate
+ pkgdesc = A pep8 equivalent for bash scripts
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/openstack-dev/bashate
+ arch = any
+ license = Apache
+ makedepends = setuptools
+ depends = python
+ source = http://pypi.python.org/packages/source/b/bashate/bashate-0.2.0.tar.gz
+ md5sums = 809b2eb1d7a5aea83f6ef64eefdcfef6
+
+pkgname = bashate
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..01dc39f2de9f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/bashate-*
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aa3c13565ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Christoph Gysin <christoph.gysin@gmail.com>
+pkgname=bashate
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A pep8 equivalent for bash scripts"
+arch=('any')
+makedepends=('setuptools')
+depends=('python')
+url="https://github.com/openstack-dev/${pkgname}"
+license=('Apache')
+source=(http://pypi.python.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('809b2eb1d7a5aea83f6ef64eefdcfef6')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ python2 setup.py install \
+ --skip-build \
+ --optimize=1 \
+ --prefix=/usr \
+ --root=${pkgdir}
+}