summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHristo Kamenov2019-09-05 11:12:57 +0200
committerHristo Kamenov2019-09-05 11:28:21 +0200
commit83b705c064c67f6cf7c058256b02bd2e97d1366b (patch)
tree57ccfcaaa545bd3c9f1bfb643a9d04eea04990b9
downloadaur-83b705c064c67f6cf7c058256b02bd2e97d1366b.tar.gz
feat: Added first PKGBUILD
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8078e3905230
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bashball
+ pkgdesc = A tool for compiling bash projects in a single script
+ pkgver = 1.6.3
+ pkgrel = 1
+ url = https://github.com/blkgoose/bashball
+ arch = any
+ license = GPL
+ depends = bash
+ source = https://github.com/blkgoose/bashball/releases/download/v1.6.3/bashball
+ md5sums = 122df628791cc763c12d665920aa94e7
+
+pkgname = bashball
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6be62b09232e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Hristo Kamenov <hkamenov123@gmail.com>
+pkgname=bashball
+pkgver=1.6.3
+pkgrel=1
+pkgdesc="A tool for compiling bash projects in a single script"
+arch=('any')
+url="https://github.com/blkgoose/bashball"
+license=('GPL')
+depends=('bash')
+source=("https://github.com/blkgoose/bashball/releases/download/v$pkgver/bashball")
+md5sums=('122df628791cc763c12d665920aa94e7')
+
+package() {
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}