summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-07-28 01:57:08 -0400
committerChris Severance2015-07-28 01:57:08 -0400
commit6638c09e50e927fb6becf97043088f21d48a3dbf (patch)
tree5fbe99785bf775fb6f5729bfb942055ae895db0c
downloadaur-6638c09e50e927fb6becf97043088f21d48a3dbf.tar.gz
Initial Import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD45
-rw-r--r--bashc.install10
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a69bce37f117
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bashc
+ pkgdesc = A version of the GNU Bourne Again shell extended with two-panel OFM file manager.
+ pkgver = 3.2.33.0
+ pkgrel = 4
+ url = http://Groups.google.com/group/bashc
+ install = bashc.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ backup = etc/bash_commander
+ backup = etc/bash_dialog
+ source = http://downloads.sourceforge.net/bashc/bashc-3.2.33.0.tgz
+ sha256sums = d8cd2a20628ab6aee7d89ec4e3a0163d2b1cb4d7d3e135af3f82474c5d3e6cb8
+
+pkgname = bashc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..209ebda0ff3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Nathan Owe <ndowens at archlinux.us>
+
+set -u
+pkgname='bashc'
+pkgver='3.2.33.0'
+pkgrel='4'
+pkgdesc='A version of the GNU Bourne Again shell extended with two-panel OFM file manager.'
+url='http://Groups.google.com/group/bashc'
+#url='http://sourceforge.net/projects/bashc/'
+#url='https://github.com/sergev/bash-commander'
+depends=('ncurses')
+license=('GPL')
+install="${pkgname}.install"
+arch=('i686' 'x86_64')
+backup=('etc/bash_commander' 'etc/bash_dialog')
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tgz")
+sha256sums=('d8cd2a20628ab6aee7d89ec4e3a0163d2b1cb4d7d3e135af3f82474c5d3e6cb8')
+
+prepare() {
+ set -u
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix='/' --bindir='/usr/bin' --sbindir='/usr/bin' --sysconfdir="/etc/${pkgname}" --with-curses
+ set +u
+}
+
+build() {
+ set -u
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -s -j $(nproc)
+ set +u
+}
+
+package() {
+ set -u
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Ensure there are no forbidden paths (git-aurcheck)
+ #! grep -alqr "/sbin" "${pkgdir}" || echo "${}" # Only one instance left and it's POSIX
+ #! grep -alqr "/usr/tmp" "${pkgdir}" || echo "${}" # This is fail over so it's OK
+ ! test -d "${pkgdir}/usr/sbin" || echo "${}"
+ set +u
+}
+set +u
diff --git a/bashc.install b/bashc.install
new file mode 100644
index 000000000000..90a18f31916b
--- /dev/null
+++ b/bashc.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo ""
+ echo ">> Change the following line in /etc/passwd:"
+ echo " root:x:0:0:root:/root:/bin/bash to"
+ echo " root:x:0:0:root:/root:/bin/bashc"
+ echo " and do the same with the useraccounts."
+ echo ""
+ echo ">> Add . /etc/bash_commander to ~/.bashrc. This will load"
+ echo " the bashc config. For config examples look at: http://groups.google.com/group/bashc"
+}