summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 16:52:33 +0100
committerBartłomiej Piotrowski2018-01-05 16:52:33 +0100
commit78f1c57a84de39e1072fb1df9783b0326fb51f01 (patch)
treebafe35aef5f86f69b810749b5c3f2aead8a310d3
downloadaur-78f1c57a84de39e1072fb1df9783b0326fb51f01.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
-rw-r--r--python2.patch9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d942d1d965b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bashdb
+ pkgdesc = A debugger for Bash scripts loosely modeled on the gdb command syntax
+ pkgver = 4.3_0.9
+ pkgrel = 4
+ url = http://bashdb.sourceforge.net/
+ arch = any
+ license = GPL
+ depends = bash
+ depends = python2-pygments
+ depends = pygmentize
+ source = http://downloads.sourceforge.net/bashdb/bashdb-4.3-0.9.tar.bz2
+ source = python2.patch
+ md5sums = 2f2479933a4e19663349b66f87d0290a
+ md5sums = 7e2fdd6ecb69cfd2cc2dba33c700c800
+
+pkgname = bashdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da069f4468b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 194152 2016-10-31 13:48:24Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+pkgname=bashdb
+pkgver=4.3_0.9
+pkgrel=4
+pkgdesc="A debugger for Bash scripts loosely modeled on the gdb command syntax"
+arch=('any')
+url="http://bashdb.sourceforge.net/"
+license=('GPL')
+depends=('bash' 'python2-pygments' 'pygmentize')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-${pkgver/_/-}.tar.bz2 python2.patch)
+md5sums=('2f2479933a4e19663349b66f87d0290a'
+ '7e2fdd6ecb69cfd2cc2dba33c700c800')
+
+prepare() {
+ cd $pkgname-${pkgver//_/-}
+ patch -Np1 -i "$srcdir"/python2.patch
+ sed -i "s#'4.2' | '4.1'#'4.3' | '4.2' | '4.1'#" configure
+}
+
+build() {
+ cd $pkgname-${pkgver//_/-}
+ ./configure --prefix=/usr --disable-static -C
+ make
+}
+package() {
+ cd $pkgname-${pkgver//_/-}
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/share/info/dir
+}
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..78f2287ec826
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,9 @@
+diff -aur bashdb-4.2-0.7/lib/term-highlight.py bashdb-4.2-0.7.new//lib/term-highlight.py
+--- bashdb-4.2-0.7/lib/term-highlight.py 2011-03-07 17:05:56.000000000 -0800
++++ bashdb-4.2-0.7.new//lib/term-highlight.py 2011-03-17 14:19:01.676694024 -0700
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ # from pydbgr.api import debug
+ # debug()
+ from pygments import highlight